myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Entwicklung » Grundlagen von C# » Window wird nicht gefunden?
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

geschlossen (weitere Infos)
Zum Ende der Seite springen  

Window wird nicht gefunden?

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland


Xalo ist offline

Window wird nicht gefunden?

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

da mein Post gestern gelöscht worden ist(Ich weiß leider nicht wieso) stelle ich hier meine Frage noch einmal.
Ich studiere im 5 Semester Wirtschaftsinformatik und habe jetzt von meinem Chef die Aufgabe bekommen, ein Programm zu entwickeln was eine Client Server Verbindung herstellt und in dem ich dann einige Aufgabe erledigen kann.
Ich arbeite mit dem .Net Framework und SignalR.
Auf folgender Seite:  https://docs.microsoft.com/de-de/aspnet/...s=visual-studio
hab ich den Code ganz oben in mein VS übertragen nur kriege ich folgenden Fehler.
(Hier ist ein Codeschnipsel)

C#-Code:
namespace SignalRChatClient
{
    public partial class MainWindow : Window  <-- Und genau da hab ich meinen Fehler.
    {
        HubConnection connection;
        public MainWindow()
        {
            InitializeComponent();

Ich kriege die Fehlermeldung CS0246 aber ich weis nicht was ich dagegen machen soll.
Ich wäre für eure Hilfe sehr Dankbar.
Mit freundlichen Grüßen
Xalo
15.09.2020 14:55 Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 14.208
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

15.09.2020 15:05 Beiträge des Benutzers | zu Buddylist hinzufügen
witte
myCSharp.de-Mitglied

Dabei seit: 03.09.2010
Beiträge: 911


witte ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

... und mal sagen von welchem Typ das verewendete Projekt ist.
15.09.2020 15:07 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland

Themenstarter Thema begonnen von Xalo

Xalo ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Was ist den jetzt falsch an der Frage?
15.09.2020 15:08 Beiträge des Benutzers | zu Buddylist hinzufügen
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland

Themenstarter Thema begonnen von Xalo

Xalo ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Wie meinst du das von welchem Typen?
Also ich benutze das .Net Framework mit SignalR falls du das meinst.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Xalo am 15.09.2020 15:18.

15.09.2020 15:10 Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 14.208
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat:
Ich kriege die Fehlermeldung CS0246 aber ich weis nicht was ich dagegen machen soll.

>  [FAQ] CS0234 / CS0246 - Der Typ- oder Namespacename "Foo" konnte nicht gefunden werden

Zitat:
Was ist den jetzt falsch an der Frage?

Vor dem Posten mal in die FAQ schauen, dann hättest den Link direkt gesehen ;-)
15.09.2020 15:14 Beiträge des Benutzers | zu Buddylist hinzufügen
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland

Themenstarter Thema begonnen von Xalo

Xalo ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hab ich gemacht, sonst hätte ich ja die Frage nicht gestellt oder ;) scheint nicht deine beste Antwort gewesen zu sein;-) aber ja danke dir trotzdem für deine "Hilfe", vielleicht bringt das jemand anderem weiter.
15.09.2020 15:18 Beiträge des Benutzers | zu Buddylist hinzufügen
T-Virus T-Virus ist männlich
myCSharp.de-Mitglied

Dabei seit: 17.04.2008
Beiträge: 1.599
Entwicklungsumgebung: Visual Studio, Codeblocks, Edi
Herkunft: Nordhausen, Nörten-Hardenberg


T-Virus ist offline Füge T-Virus Deiner Kontaktliste hinzu

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Vermutlich hast du die using nicht mit kopiert, weshalb du die Meldung bekommst.
Window dürfte ohne System.Windows vermutlich unbekannt sein.

T-Virus
15.09.2020 15:22 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 14.208
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Zitat von Xalo:
Hab ich gemacht, sonst hätte ich ja die Frage nicht gestellt oder ;) scheint nicht deine beste Antwort gewesen zu sein;-)

In dem Link steht die Lösung, wie Dein Fehler behoben wird.
Lesen scheint nicht Deine Stärke zu sein ;-)
15.09.2020 15:23 Beiträge des Benutzers | zu Buddylist hinzufügen
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland

Themenstarter Thema begonnen von Xalo

Xalo ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ja ich schau da mal genauer nach.

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von Xalo am 15.09.2020 15:49.

15.09.2020 15:29 Beiträge des Benutzers | zu Buddylist hinzufügen
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland

Themenstarter Thema begonnen von Xalo

Xalo ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ich hab eigentlich die richtigen usings drine. auch das using System.
15.09.2020 15:44 Beiträge des Benutzers | zu Buddylist hinzufügen
T-Virus T-Virus ist männlich
myCSharp.de-Mitglied

Dabei seit: 17.04.2008
Beiträge: 1.599
Entwicklungsumgebung: Visual Studio, Codeblocks, Edi
Herkunft: Nordhausen, Nörten-Hardenberg


T-Virus ist offline Füge T-Virus Deiner Kontaktliste hinzu

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Scheinbar ja nicht, sonst hättest du die Meldung nicht.

 System.Windows.Window

T-Virus
15.09.2020 15:53 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Xalo Xalo ist männlich
myCSharp.de-Mitglied

Dabei seit: 14.09.2020
Beiträge: 9
Entwicklungsumgebung: Visual Studios
Herkunft: Deutschland

Themenstarter Thema begonnen von Xalo

Xalo ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Das hier ist mein ganzer Code.



using System;
using System.Threading.Tasks;
using Microsoft.AspNetCore.SignalR.Client;
using System.Windows.;



namespace SignalRChatClient

{
public partial class MainWindow : Window
{
HubConnection connection;
public MainWindow()
{
InitializeComponent();

connection = new HubConnectionBuilder()
.WithUrl("http://localhost:53353/ChatHub")
.Build();

connection.Closed += async (error) =>
{
await Task.Delay(new Random().Next(0, 5) * 1000);
await connection.StartAsync();
};
}

private async void connectButton_Click(object sender, RoutedEventArgs e)
{
connection.On<string, string>("ReceiveMessage", (user, message) =>
{
this.Dispatcher.Invoke(() =>
{
var newMessage = $"{user}: {message}";
messagesList.Items.Add(newMessage);
});
});

try
{
await connection.StartAsync();
messagesList.Items.Add("Connection started");
connectButton.IsEnabled = false;
sendButton.IsEnabled = true;
}
catch (Exception ex)
{
messagesList.Items.Add(ex.Message);
}
}

private async void sendButton_Click(object sender, RoutedEventArgs e)
{
try
{
await connection.InvokeAsync("SendMessage",
userTextBox.Text, messageTextBox.Text);
}
catch (Exception ex)
{
messagesList.Items.Add(ex.Message);
}
}
}
}
15.09.2020 15:55 Beiträge des Benutzers | zu Buddylist hinzufügen
T-Virus T-Virus ist männlich
myCSharp.de-Mitglied

Dabei seit: 17.04.2008
Beiträge: 1.599
Entwicklungsumgebung: Visual Studio, Codeblocks, Edi
Herkunft: Nordhausen, Nörten-Hardenberg


T-Virus ist offline Füge T-Virus Deiner Kontaktliste hinzu

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Kein wunder, dass er nicht klappt, wenn dein using fehlerhaft eingefügt ist.

C#-Code:
// Punkt am Ende sollte eigentlich Fehlermeldung erzeugen!
using System.Windows.;

Anbei wäre es hilfreich, wenn du die Code Tags verwendest.
Keiner hat Lust den Code so zu lesen.

T-Virus

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von T-Virus am 15.09.2020 15:58.

15.09.2020 15:58 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Th69
myCSharp.de-Poweruser/ Experte

avatar-2578.jpg


Dabei seit: 01.04.2008
Beiträge: 3.739
Entwicklungsumgebung: Visual Studio 2015/17


Th69 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hast du denn überhaupt ein WPF .NET Core Projekt? Und welche Visual Studio Version verwendest du (die neueste, also 2019)? s.a.  Creating a .NET Core 3 WPF app

PS: Formatiere mal deinen Code hier richtig.
Du hast nämlich einen Punkt "." zu viel bei richtigerweise using System.Windows;
Diesen sollte der Compiler auch anmeckern.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Th69 am 15.09.2020 15:59.

15.09.2020 15:58 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 14.208
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Erneuter Cross Post
 https://www.java-forum.org/thema/das-run...t-nicht.189433/

Danke für das Melden!
15.09.2020 16:02 Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum
geschlossen (weitere Infos)


© Copyright 2003-2020 myCSharp.de-Team | Impressum | Datenschutz | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 29.09.2020 10:16