myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Entwicklung » Basistechnologien und allgemeine .NET-Klassen » Auf was soll ich von .NET 4.6.1 aus upgraden?
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

Antwort erstellen
Zum Ende der Seite springen  

Auf was soll ich von .NET 4.6.1 aus upgraden?

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
sugar76 sugar76 ist männlich
myCSharp.de-Mitglied

Dabei seit: 19.10.2017
Beiträge: 64
Entwicklungsumgebung: Visual Studio, IntelliJ IDEA
Herkunft: Berlin


sugar76 ist offline

Auf was soll ich von .NET 4.6.1 aus upgraden?

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo,

ich arbeite an einer WPF-Anwendung, die aktuell unter .NET 4.6.1 läuft. Clients sind alle Windows 10.

Ich will nun die .NET Version im Rahmen eines Wartungsupdates aktualisieren.

Nun ist die Frage, ob ich auf .NET 4.8 oder auf .NET Core 3.1 aktualisiere.

Bei .NET 4.8 habe ich keine Bedenken.

Bei .NET Core ist es anders:
- laufen alle Bibliotheken unter .NET Core (z.B. Microsoft.ReportViewer.Winforms)?
- läuft eine .NET Core Anwendung auf allen Windows 10 Clients?

Wie steht ihr dazu? Hat jemand schon mal eine WPF-Anwendung auf .NET Core migriert und welche Probleme gab es dabei?

Gruß smile
25.03.2020 13:52 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Abt
myCSharp.de-Team

avatar-4119.png


Dabei seit: 20.07.2008
Beiträge: 13.593
Herkunft: Stuttgart/Stockholm


Abt ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Das kann Dir hier keiner beantworten; wir kennen weder Dein Projekt noch Deine Anforderungen bzw. Bibliotheksanforderungen.
Ob gewisse Bibliotheken laufen: das kannst ja selbst googlen. Müssen nicht wir für Dich tun.
Das Forum ist ja kein Migrationsdienstleister :-)


Der Nachfolger von .NET 4.8 -> .NET 4.9 ist übrigens  .NET 5 - nicht .NET Core 3.1
Unter 3.1 wird Du sicherlich deutlich mehr finden, was nicht funktioniert, als in .NET 5.

Und je nachdem was Deine Anwendung so tut, musst Du gewisse Dinge in Deiner Anwendung ersetzen, weil es diese in .NET 5 nicht oder eben in anderer Form gibt.
25.03.2020 15:18 Beiträge des Benutzers | zu Buddylist hinzufügen
witte
myCSharp.de-Mitglied

Dabei seit: 03.09.2010
Beiträge: 853


witte ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hast du mal den  portability-analyzer getestet?
25.03.2020 15:50 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum
Antwort erstellen


© Copyright 2003-2020 myCSharp.de-Team | Impressum | Datenschutz | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 05.04.2020 10:48