myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Entwicklung » GUI: Windows-Forms » Darstellungsproblem in (MDI) Container
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

Antwort erstellen
Zum Ende der Seite springen  

Darstellungsproblem in (MDI) Container

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Bonaqua
myCSharp.de-Mitglied

Dabei seit: 24.10.2011
Beiträge: 16


Bonaqua ist offline

Darstellungsproblem in (MDI) Container

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Unser Projekt soll nun in einen Container eingebettet werden.
Ein Test war in einem MDI-Container, beim anderen wurde ein Panel als Container verwendet.
Hat (eigentlich) auch beides geklappt.

Nun haben wir aber - bei beiden Varianten - festegestellt, dass die Darstellung nicht immer korrekt ist.
Z.B. wird eine DataGridView aufgerufen, bei dieser bestimmte Zellen abhängig vom Datum, farblich markiert werden.
Die farbliche Darstellung wird aber in beiden Fällen nicht dargestellt. Beim "normalen" Aufruf der Form allerdings schon.
An was liegt das? Muss an der Aufrufreihenfolge etwas geändert werden?

Und welche Variante des Containers ist zu bevorzugen? Die von VS vorgeschlagene Variante über IsMdiContainer oder über das Panel?
13.12.2019 11:33 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Th69
myCSharp.de-Poweruser/ Experte

avatar-2578.jpg


Dabei seit: 01.04.2008
Beiträge: 3.471
Entwicklungsumgebung: Visual Studio 2015/17


Th69 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Ist evtl. die Ereigniszuweisung für CellFormatting (oder welches Ereignis ihr auch dafür benutzt) verloren gegangen (bzw. nicht neu gesetzt worden)?
13.12.2019 11:38 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum Der Startbeitrag ist älter als 2 Monate.
Der letzte Beitrag ist älter als 2 Monate.
Antwort erstellen


© Copyright 2003-2020 myCSharp.de-Team | Impressum | Datenschutz | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 29.02.2020 10:53