myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Entwicklung » Entwicklungs- und Laufzeitumgebung (Infrastruktur) » [Erledigt] WebDeploy / WebDeploy Package schlägt fehl wegen derselben Projektsammlung
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

Antwort erstellen
Zum Ende der Seite springen  

[Erledigt] WebDeploy / WebDeploy Package schlägt fehl wegen derselben Projektsammlung

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
t0ms3n t0ms3n ist männlich
myCSharp.de-Mitglied

Dabei seit: 13.01.2013
Beiträge: 314


t0ms3n ist offline

[Erledigt] WebDeploy / WebDeploy Package schlägt fehl wegen derselben Projektsammlung

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo zusammen,

ich habe eine ASP.NET Core Applikation. Diese habe ich bisher über WebDeploy bereitgestellt (VS2017). Dies schlägt nun seit Freitag plötzlich aus mir nicht erkennbaren Gründen fehl.

Fehlermeldung:
4>------ Publish started: Project: .........., Configuration: Debug Any CPU ------
Alle Buildübermittlungen in einem Build müssen Projektinstanzen aus derselben Projektsammlung verwenden.

4>Publish failed due to build errors. Check the error list for more details.
========== Build: 3 succeeded, 0 failed, 1 up-to-date, 0 skipped ==========
========== Publish: 0 succeeded, 1 failed, 0 skipped ==========

Probiert habe ich:
- Clean / Rebuild
- Löschen von bin und obj
- Output verbosity mit Diagnostic hat mir auch keine weiteren Infos geliefert
- WebDeploy Package anstelle von WebDeploy

Lokal kann ich die Applikation problemlos builden und auch starten. Eine andere ASP.NET Core Applikation lässt sich problemlos deployen.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von t0ms3n am 24.07.2017 10:00.

24.07.2017 09:53 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
t0ms3n t0ms3n ist männlich
myCSharp.de-Mitglied

Dabei seit: 13.01.2013
Beiträge: 314

Themenstarter Thema begonnen von t0ms3n

t0ms3n ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Erledigt, eine Drittanbieter DLL, welche von einem Projekt expliziert mitgeliefert wird, stand auf "Copy Always". Anscheinend wurde eine andere Version bereits mitgeliefert, sodass dies zu Konflikten geführt hat.

"Copy if newer" hat jedenfalls geholfen. Nun mal noch schauen welche Versionskonflikte dort auftreten.
24.07.2017 09:59 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum Der Startbeitrag ist älter als 3 Jahre.
Der letzte Beitrag ist älter als 3 Jahre.
Antwort erstellen


© Copyright 2003-2020 myCSharp.de-Team | Impressum | Datenschutz | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 22.10.2020 14:01