myCSharp.de - DIE C# und .NET Community
Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 
 | Suche | FAQ

» Hauptmenü
myCSharp.de
» Startseite
» Forum
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Suche
» Regeln
» Wie poste ich richtig?
» Forum-FAQ

Mitglieder
» Liste / Suche
» Wer ist wo online?

Ressourcen
» openbook: Visual C#
» openbook: OO
» Microsoft Docs

Team
» Kontakt
» Übersicht
» Wir über uns

» myCSharp.de Diskussionsforum
Du befindest Dich hier: Community-Index » Diskussionsforum » Entwicklung » Netzwerktechnologien » [erledigt] WCF Inhaltstyp Fehler am Client
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen

Antwort erstellen
Zum Ende der Seite springen  

[erledigt] WCF Inhaltstyp Fehler am Client

 
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Pico1184 Pico1184 ist männlich
myCSharp.de-Mitglied

avatar-2893.jpg


Dabei seit: 21.05.2009
Beiträge: 220
Entwicklungsumgebung: Visual Studio 2019
Herkunft: Karlsruhe


Pico1184 ist offline

[erledigt] WCF Inhaltstyp Fehler am Client

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo zusammen,

habe einen WCF Service mit folgender Konfiguration:

XML-Code:
<system.webServer>
<modules runAllManagedModulesForAllRequests="true"/>
</system.webServer>
<system.serviceModel>
<bindings>
<basicHttpBinding>
<binding name="BasicHttpBindingConfiguration" maxReceivedMessageSize="9965536"> <readerQuotas maxArrayLength="9965536" />
</binding>
</basicHttpBinding>
<ws2007HttpBinding>
<binding name="WS2007BindingConfiguration" maxReceivedMessageSize="9965536"> <readerQuotas maxArrayLength="9965536" />
</binding>
</ws2007HttpBinding>
</bindings>
<behaviors>
<serviceBehaviors>
<behavior name="">
<serviceMetadata httpGetEnabled="true" />
<serviceDebug includeExceptionDetailInFaults="true" />
<serviceDiscovery />
</behavior>
</serviceBehaviors>
</behaviors>
<services>
<service name="VisualControl.DisribitedServices.StudioService">
<clear />
<endpoint address="basic" binding="basicHttpBinding" bindingConfiguration="BasicHttpBindingConfiguration" name="BasicBindingForSilverlightClients" contract="VisualControl.DistributedServices.StudioService.IStudioService" listenUriMode="Explicit"/>
<endpoint address="WS2007" binding="ws2007HttpBinding" bindingConfiguration="WS2007BindingConfiguration" name="WS2007ForIntranetClients" contract="VisualControl.DistributedServices.StudioService.IStudioService" />
<!--UPD discovery endpoint-->
<endpoint name="DiscoveryEndpoint" listenUriMode="Explicit" kind="udpDiscoveryEndpoint" /> </service>
</services>
<diagnostics etwProviderId="217324ec-21d1-4782-bd9e-75f32b5fabc0">
<endToEndTracing propagateActivity="true" messageFlowTracing="true" />
</diagnostics>
</system.serviceModel>

und einen Client mit folgender Konfiguration:

XML-Code:
<configuration>
<appSettings>
<add key="discovery_wcf_services" value="false"/>
</appSettings>
<system.serviceModel>
<bindings>
<ws2007HttpBinding>
<binding name="WS2007ForIntranetClients" closeTimeout="00:01:00"
openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00"
bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard"
maxBufferPoolSize="524288" maxReceivedMessageSize="99965536" messageEncoding="Text"
textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false"
>
<readerQuotas maxDepth="32" maxStringContentLength="8192"
maxArrayLength="99916384" maxBytesPerRead="4096" maxNameTableCharCount="16384"
/>
<reliableSession ordered="true" inactivityTimeout="00:10:00" enabled="false"/>
<security mode="Message">
<transport clientCredentialType="Windows" proxyCredentialType="None" realm=""/>
<message clientCredentialType="Windows" negotiateServiceCredential="true"
algorithmSuite="Default"
/>
</security>
</binding>
</ws2007HttpBinding>
</bindings>
<client>
<endpoint address="http://localhost:7407/StudioService.svc/WS2007"
binding="ws2007HttpBinding" bindingConfiguration="WS2007ForIntranetClients"
contract="Proxies.StudioService.IStudioService" name="WS2007ForIntranetClients"
>
</endpoint>
</client>
</system.serviceModel>
<startup>
<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
</startup>
</configuration>

wenn ich nun den Client connecten will bekommen ich folgende Fehlermeldung:

Zitat:
Der Inhaltstyp "application/soap+xml; charset=utf-8" wurde von Dienst"http://localhost:7407/StudioService.svc/WS2007" nicht unterstützt.Möglicherweise stimmen Client- und Dienstbindungen nicht überein.

mein discovery funktioniert ebenfalls nicht, der Client findet keinen Endpunkt!

Vielleicht kann mir jemand von euch helfen...sehe vor lauter Bäumen den Wald nicht!

Grüße Pico

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Pico1184 am 15.11.2010 14:06.

Neuer Beitrag 15.11.2010 13:08 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
serial
myCSharp.de-Mitglied

Dabei seit: 17.09.2007
Beiträge: 902
Entwicklungsumgebung: VS08


serial ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo,

hast du irgendwo eine BaseAdress hinterlegt?
Denn deine endpoints gehen ja nur auf basic bzw ws2007.

mfg
serial
Neuer Beitrag 15.11.2010 13:24 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
gfoidl gfoidl ist männlich
myCSharp.de-Team

avatar-2894.jpg


Dabei seit: 07.06.2009
Beiträge: 6.662
Entwicklungsumgebung: VS 2019
Herkunft: Waidring


gfoidl ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

Hallo,

hast du die Fehlermeldung in die Forensuche und/oder andere Suchmaschinen eingegeben?
Diese Meldung ist sowas wie ein Standardfehler ;-)


mfG Gü
Neuer Beitrag 15.11.2010 13:41 Beiträge des Benutzers | zu Buddylist hinzufügen
Pico1184 Pico1184 ist männlich
myCSharp.de-Mitglied

avatar-2893.jpg


Dabei seit: 21.05.2009
Beiträge: 220
Entwicklungsumgebung: Visual Studio 2019
Herkunft: Karlsruhe

Themenstarter Thema begonnen von Pico1184

Pico1184 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

XML-Code:
<endpoint address="http://localhost:7407/StudioService.svc/basic" binding="basicHttpBinding"
bindingConfiguration="BasicHttpBindingConfiguration" name="BasicBindingForSilverlightClients"
contract="VisualControl.DistributedServices.StudioService.IStudioService" listenUriMode="Explicit"
/>
<endpoint address="http://localhost:7407/StudioService.svc/WS2007"binding="ws2007HttpBinding"
bindingConfiguration="WS2007BindingConfiguration"name="WS2007ForIntranetClients"
contract="VisualControl.DistributedServices.StudioService.IStudioService"
/>

habs mal direkt in dei web.config geschrieben, da kommt allerdings die gleiche Fehlermeldung!

@gfoidl
Klar ich hab danach gegoogelt...aber irgendwie nix gescheites gefunden!

Zitat:
Möglicherweise stimmen Client- und Dienstbindungen nicht überein.

Ich denke doch, dass meine Bindings stimmen.....??????Grüße Pico

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Pico1184 am 15.11.2010 13:45.

Neuer Beitrag 15.11.2010 13:42 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Pico1184 Pico1184 ist männlich
myCSharp.de-Mitglied

avatar-2893.jpg


Dabei seit: 21.05.2009
Beiträge: 220
Entwicklungsumgebung: Visual Studio 2019
Herkunft: Karlsruhe

Themenstarter Thema begonnen von Pico1184

Pico1184 ist offline

Beitrag: beantworten | zitieren | editieren | melden/löschen       | Top

arrrrgggggggggg.....hab den Fehler gefunden!

Das Problem war, dass ich in der .svc Datei einen anderen ServiceName angegeben hatte als in der web.config unter <service name="">

Danke euch trotzdem!!

So blöd kann man sein!

Grüße Pico
Neuer Beitrag 15.11.2010 13:58 E-Mail | Beiträge des Benutzers | zu Buddylist hinzufügen
Baumstruktur | Brettstruktur       | Top 
myCSharp.de | Forum Der Startbeitrag ist älter als 9 Jahre.
Der letzte Beitrag ist älter als 9 Jahre.
Antwort erstellen


© Copyright 2003-2020 myCSharp.de-Team | Impressum | Datenschutz | Alle Rechte vorbehalten. | Dieses Portal verwendet zum korrekten Betrieb Cookies. 30.09.2020 02:12