Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Portal
  • |
  • Mitglieder
Beiträge von rollerfreak2
Thema: Treeview Problem mit Sitemap DataBinding()
Am im Forum: Web-Technologien

Ich hab das bind natürlich nur einmal ausgeführt. Bin ja nicht doof. Nur hast du mir noch imme rnicht gesagt wie man dort post einstellt, und im inet (google etc.) findet man dazu nichts....

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Hat den keiner von euch eine Idee warum der Tree so reagiert? ICh versteh das nämlich nicht, und kanns nicht nachvollziehen...

Thema: Treeview Problem mit Sitemap DataBinding()
Am im Forum: Web-Technologien

Irgendwie scheinst du mein Problem nicht zu verstehen...?

Also noch mal, weil ich nicht glaub das es am get bzw post liegt. ICh führe einmal Databind aus. Dann sind im Treeview OBJECT alle Nodes bzw. Childnodes enthalten. Klicke ich auf ein Link des Tree's und lande zum Beispiel im dazugehörigen Handler (treeNodeChange) dann ist das Object des Treeviews immer noch mit den Nodes gefüllt. Nur Wenn ich jetzt zum Beispiel ein Button auf der Seite habe, und diesen Betätige, und im dazugehörigen Handler lande, dann ist meine Instanz des Tree's zwar noch da, aber die Nodes sind alle leer. Das ist das Problem. Wieso sind die jetzt leer, das heißt wieso werden die Informationen über den Tree nicht auch hier mit zum Server gesendet?????

Kanns du mir vielleicht jetzt besser helfen...?

Thema: Treeview Problem mit Sitemap DataBinding()
Am im Forum: Web-Technologien

ICh benutze wahrscheinlich GET, ich fülle meinen Treeview mit einer Sitemap. Das Problem ist, ich weis nicht wo ich dort dem Treeview sagen kann das er die Links mit Get zurück senden soll (also Roundtrip zum Server). In php wüsste ich es. :-(

Hab auch schon gegoogelt, nur zum thema Treeview und GET Post, findet man nix brauchbares. Hast du/jemand einen Tip für mich?

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Jetzt gibt es doch noch ein kleines Problem welches ich nicht verstehe. Und zwar funktioniert der Treeview einwandfrei, es werden alle Ordner und auch Datein angezeigt. Jedoch, hab ich auf der Seite, wo der tree sich befindet auch noch einen Button bzw. einen anderen Treeview. Wenn man nun auf ein solchen Button klickt wird ja ein ganz normaler Postback ausgeführt. Das Problem ist dann aber, das alle Knoten des Trees die ich geöffnet habe weg sind, das heißt dort wo vorher Beispielsweise "C:User\... stand " wird jetzt "C:User" draus. Konkret jeden Ordner den ich mal angeklickt habe, und danach irgendwann auf diesen Button klicke, wird dann nicht mehr angezeigt. Das ist sehr komisch, weil es ja sonst funkioniert. Wird mich freuen wenn einer von euch weis warum dieses Verhalten entsteht!

Habs jetzt erstmal dadurch gelöst das ich den kompletten Tree lösche und neu aufbaue, aber das ist ja eigentlich schwachsinn.

Habs mal dran gehängt, da könnt ihr das besser nachvolziehen!

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Also ich habs jetzt hinbekommen. Ich kann jetzt auch die Files mit anzeigen. Auch nur bestimmte files anzeigen. Trotzdem danke für deine Hilfe.

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Ok, finds erstmal gut das du mir helfen willst. Ich hab mich jetzt ein bisschen in die Sache rein gefizzt.
Also habs jetzt soweit am laufen das mit im Treeview alle ORDNER angezeigt werden.

1. Dort hab ich noch ein kleines Porblem mit Ordnern die den Zugriff verweigern.

2. Ich hab es noch nicht hin bekommen das auch im TREEVIEW alle in den ORDNERN befindlichen Datein angeigt werden.


Wenn ich im Treeview klicke dann kann ich auch den entsprechenden Pfad auslesen.

Es reicht mir wenn ich es am Ende soweit habe, das der Treeview komplett aufgebaut ist, und wenn ich ein ELement anklicke dann soll dieser Pfad in eine Textbox geschrieben werden. Jetzt hängts aber an den Files...

Hab mal das aktuell laufende Projekt dran gehängt.

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Also du kannst mir auch nicht weiter helfen scheint mir. Hab es jetzt soweit das es läuft, nur die Files werden nicht angezeigt nur die Ordner. Es gibt doch sicherlich schon fix und fertige sachen dafür. Hat einer von euch sowas rum liegen oder weis einer von euch wo es sowas gibt.

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Ich dachte das ist ein Forum. Ich hab mich damit befasst, nur wenn ich wüsste wie es geht würd ich es hier nicht rein posten. Kannst du mir nicht einfach sagen was ich falsch mache, oder noch besser wieso das bei dem Typen so geht, ohne das er was am Code ändert und bei mir nicht.

Am besten wär du würdest dir mal mein Projekt angucken, und mir zeigen was ich da falsch mache!

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Wenn ich die 2 Fehler weg mache kommt folgender Fehler.

Error 7 Der Name sCallBackFunctionInvocation ist im aktuellen Kontext nicht vorhanden. H:\ASP.NET\exporer\Default.aspx 17

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Also folgende Fehler:

compilewith="default.aspx.cs" gibt es anscheinend nicht

->Error 1 Fehler beim Analysieren des Attributs compilewith: Der Typ System.Web.UI.Page hat keine öffentliche Eigenschaft mit dem Namen compilewith. H:\ASP.NET\exporer\Default.aspx 1

ImageSet="XP_Explorer" kommt folgender Fehler

Error 2 Objekt des Typs System.Web.UI.WebControls.TreeViewImageSet kann nicht von seiner Zeichenfolgendarstellung XP_Explorer für die ImageSet-Eigenschaft erstellt werden. H:\ASP.NET\exporer\Default.aspx 89

Wenn ich die beiden Sachen raus nehme geht es erst richtig los. Ca 10 weitere Fehler kommen dann.
Deswegen hab ich es hinten dran gehängt das sich das mal jemand anguckt, ob er auch solche Fehler bekommt. Versteh nicht, hab das einfach kopiert, warum geht das bei dem, und bei mir nicht...

Thema: Client Site Explorer funktioniert nicht
Am im Forum: Web-Technologien

Ich hab hier <http://www.dotnetjunkies.com/Tutorial/E80EC96F-1C32-4855-85AE-9E30EECF13D7.dcik> im Internet ein tolles java applet gefunden für eine client seitigen Explorer mit dem man Beispielsweise Upload's sehr elegant gestallten kann. Problem nur ist ich bekomm das Teil nicht zum laufen. Bekomme die Fehler nicht weg, was ich komisch finde da ich auch das Framework 2.0 und Visual Studio 2005 benutze.

Kann mir einer helfen, hab das Project mal hinten dran gehängt.

Danke im Vorraus...

Thema: Treeview (Datasource = Sitemap) Postback beim klicken auf link
Am im Forum: Web-Technologien

Versteh ich nicht so richtig wie du das meinst. Also wo kann ich nun einstellen das dieser TREEVIEW Postback bei Event click machen soll. Weil im dazugehörigen CS file gibt es keine solche einstellung. Also kann ich es nur noch in der aspx codieren. Weis aber nicht wo?

Hast du ein Codebeispiel?

Hab mal ein einfaches Beispiel mit einer Masterpage (dort der Treeview) und drei seiten gemacht. Kannst du dir das mal angucken?

Thema: Treeview (Datasource = Sitemap) Postback beim klicken auf link
Am im Forum: Web-Technologien

Ich habe mal eine Frage. Ich hab ein Porblem mit meinem Treeview Objekt auf einer Masterpage. Ich möchte gern den Zustand meines Trees speichern. Problem nur ist, wenn ich auf einen Eintrag des Trees klicke dann wird kein POSTBACK auf die Masterpage ausgeführt, damit auch kein Round Trip zum Server, das hat zur Folge das der Server nicht den aktuellen Zustand des Trees kennt.

Sprich ich muss es einfach nur hinbekommen das wenn man auf den Treeview klickt, ein Postback ausgeführt wird. Sonst komme ich nicht an den AKTUELLEN Zustand des Trees.

Ein hinzufügen einzelner Eventhandler wie zum beispiel OnSelectedNodeChanged birngt NATÜRLICH auch nix, da ja das Event nicht kommen kann, wenn kein Round Trip, dann auch kein Event.

Es hängt alles an diesem Postback. hat einer von euch ne Ahnung wie ich das hin bekomme?

Bitte um Hilfe, bin am verzweifeln.....

Vielen Dank im Vorraus....

Thema: Treeview Problem mit Sitemap DataBinding()
Am im Forum: Web-Technologien

Hat den keiner von euch ne Ahnung wieso databind() den zusand des Tree's nicht übernimmt bzw wie ich die notes mit den ordentlichen zustand fülle!

Thema: Treeview Problem mit Sitemap DataBinding()
Am im Forum: Web-Technologien

Ich hab ein Problem mit meinem Treeview Control.
Ich habe den treeview via Datasource (sitemap) die daten zur verfügung gestellt. Das klappt auch alles bestens. Nun wollt ich mal schauen ob im Treeview auch alle Nodes und Childnotes aufgeführt sind. Dieses war nicht so. Also hab ich treeview.databind() aufgerufen. Nun sind die Notes auch alle in meiner Instanz von Treeview gewesen.

Jetzt kommt ide ertse komische sache. Nach neu laden der Seite (treeview ist in einer Masterpage eingbaut) sind die Nodes wieder aus dem Treeview raus und ich muss databind() neu aufrufen.

Jetzt kommt aber damit das nächste Problem. Ich hab mir eine Klasse geschrieben die die Zustände der Nodes speichert. (expanded oder nicht).

Komisch ist jetzt aber wenn der Tree einen bestimmten Zustand hat, z.B. die ersten 2 sind eingeklappt und die 2 anderen sind ausgeklappt. Wenn ich databind aufrufe sind jetzt aber alle Nodes und Childnodes mit "expanded = true" was mich sehr stört denn so kann ich meinen Zustand des Treeviews nicht ordentlich speichern. Das laden klappt allerdings Problemlos, sprich schreibend kann ich auf expanded ohen Problem zugreifen.

Kann mir einer helfen?