Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Outlook Add In Installation mit VSTO verursacht Probleme
morbus85
myCSharp.de - Member



Dabei seit:
Beiträge: 84

Themenstarter:

Outlook Add In Installation mit VSTO verursacht Probleme

beantworten | zitieren | melden

Hallo zusammen,

ich glaub dieses Problem trat öfters bei vielen auf und zwar, dass man die Add Ins, besonders fürs Outlook, schlecht deinstallieren und später neuinstallieren kann.
Sprich es kommt jedes mal ein Fehler, der aussagt, dass das Add In immer noch installiert sei mit der selben Assembly.

Nach eigener Erforschung hab ich einige Wege gefunden und auch im Internet auf ein halbwegs vernünftige Lösung bin ich gestoßen.

Meine:
Deinstallation durch Programme entfernen in Systemsteuerung. Dazu kommt es, dass man durch das Suchmenü im Ordner C:\User\[username]\AppData\Local nach verbleibenden Elementen sucht und sie manuell löscht.
Die Neuinstallation funktioniert oft ohne Probleme.
Dieser Weg funktioniert nur unter Windows 7

Unter XP muss man einen anderen Weg wählen. Diesen Weg, den Ansatz, fand ich im Internet:
Zuerst unter Software entfernen in Systemsteuerung. Dann jedoch muss ich den Anwendungs-Cache löschen. Das Tool MAGE.EXE gibt es, wenn man VS 2010 installiert hat. Es löscht den Cache, jedoch hat es eine kleinere Nebenwirkung, es kann sein, dass Add Ins sich automatisch abschalten.

Sprich, ich brauche eine Erklärung, warum es so schwer ist mit dotNet 4 Add Ins zu installieren und zu deinstallieren?
Und gibt es eine Lösung ohne Kopfschmerzen?

Und warum funktionieren Add Ins, die ich für Office 2007 unter XP mit dotNet 3.5 erstellt habe, einwandfrei und lassen sich ganz normal entfernen und installieren?

Zwar fand ich bestimmte Dokumentationen bei MSDNA & Co, aber keine ausreichende. Es scheint mir so, dass die Spalte Office Programmierung eine ziemlich magere Spalte sei.
private Nachricht | Beiträge des Benutzers
user8744
myCSharp.de - Member



Dabei seit:
Beiträge: 1201

beantworten | zitieren | melden

Deployment und VSTO ist tatsächlich keine schöne Sache.
Welche VSTO Version benutzt du denn?

Auf Wikipedia findest du eine Übersicht welche VSTO Versionen welche
.NET und Office Version unterstützen.

http://en.wikipedia.org/wiki/Visual_Studio_Tools_for_Office
private Nachricht | Beiträge des Benutzers
morbus85
myCSharp.de - Member



Dabei seit:
Beiträge: 84

Themenstarter:

beantworten | zitieren | melden

Eigentlich hab ich VSTO .NET 4 x86 installiert und davor für .NET 3.5.
Unter den Programmen steht bei mir Visual Studio Tools for Office Secound Runtime.

Ich habe VS 2010 Pro, da sind die meisten Tools schon mit drin, bis auf das eine Programm - vstor40_x86 , damit ich VSTO Dateien ausführen kann.
private Nachricht | Beiträge des Benutzers