Laden...

Assembly in Webprojekt wird nicht gefunden

Erstellt von Blue_Dragon vor 12 Jahren Letzter Beitrag vor 12 Jahren 1.963 Views
B
Blue_Dragon Themenstarter:in
198 Beiträge seit 2005
vor 12 Jahren
Assembly in Webprojekt wird nicht gefunden

Hallo,

Ich entwickle im Moment ein kleines ASP.NET Projekt für einen Bekannten, indem ich in eine MySql Datenbank schreiben muss.

Also habe ich mir den mySQL Connector für .NET heruntergeladen und installiert. Ich habe mir die Assembly MySql.Data.dll in das bin Verzeichnis meines Projekts kopiert und diese anschließend Referenziert.

Wenn ich es bei mir lokal builde, funktioniert alles ohne Probleme.

Wenn ich es jedoch auf dem Server lade, bekomme ich den Fehler, dass er die Assembly nicht findet, obwohl sie im /Bin Verzeichnis der Applikation liegt.

Hat jemand von euch vielleicht Tipps für mich wie ich das beheben kann?

Lg

16.788 Beiträge seit 2008
vor 12 Jahren

Hi,

hast Du die Referenz auch in der web.config stehen?
Beachte, dass sich die web.config aus der web.debug.config oder web.release.config zusammen setzen kann - je nach Modus

Wird die web.config sauber auf den Server übertragen?
Wie lautet die Wort-wörtliche Fehlermeldung? Gibts mehr Infos im Ausgabefenster?

Gruß

B
Blue_Dragon Themenstarter:in
198 Beiträge seit 2005
vor 12 Jahren

Hallo,

Die Assembly hab ich so hinzugefügt:


    <compilation>
      <assemblies>
        <add assembly="MySql.Data, Version=5.0.9.0, Culture=neutral, PublicKeyToken=C5687FC88969C44D"/>
      </assemblies>
    </compilation>

Die Fehlermedudng ist folgende:

Parserfehlermeldung: Die Datei oder Assembly "MySql.Data, Version=5.0.9.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.

T
307 Beiträge seit 2008
vor 12 Jahren

Dann fehlt vielleicht nur eine Abhängigkeit von der MySql-Dll? Das schon überprüft?