Laden...

Timeout bei Verbindung

Letzter Beitrag vor 13 Jahren 8 Posts 4.879 Views
Timeout bei Verbindung

verwendetes Datenbanksystem: MS SQL Server 2005 Express

Hallo zusammen,

ich bekomme ein Problem bei einer Verbindung zum SQL Server Express. Timeout sei abgelaufen. Das an sich wäre ja noch nicht komisch, aber die Verbindung vom Management Studio aus klappt einwandfrei, während die Verbindung vom eigenen Programm immer am Timeout scheitert.

Das System befindet sich in einem Firmennetzwerk hinter einer Firewall, wobei auf jedem Rechner nochmal eine Client-Firewall drauf ist, die aber per Richtlinie auf Durchzug geschalten ist (Ports sind offen), beim Server selbst sind die Ports 1433 und 1434 auch auf. Wobei, wenn es wirklich an der Firewall liegen würde, dann würde ja erst gar keine TCP/IP-Verbindung zustande kommen?!?

Der Server ist Windows 7, der Client ist XP, falls das jemandem was nützt.

Vielen Dank schonmal

Georg

Na klappt denn ein Ping/Telnet auf die Kiste bzw auf den Port vom Client aus?

Ping hab ich nicht probiert, aber die Verbindung vom Management Studio klappt ja.

Der verwendete Connectionstring ist "Data Source=G63W26\SQLSERVER;Initial Catalog=Dokumentation;Integrated Security=True" und ist mit dem ConnectionStringBuilder zusammengebaut, sollte also keine grammatischen Fehlerchen wie vergessenes Semikolon oder so aufweisen.

Hallo,

gib im Connectionstring explizit an dass es sich um eine TCP-Verbindung und Portangabe handelt.


Data Source=tcp:G63W26\SQLSERVER,1433;Initial Catalog=Dokumentation;Integrated Security=True

Wobei ich mir nicht sicher bin ob er "G63W26" kapiert. Ich gebe immer die IP-Adresse an. Siehe für nähere Infos die SQL Server Dokumention.

mfG Gü

Stellt fachliche Fragen bitte im Forum, damit von den Antworten alle profitieren. Daher beantworte ich solche Fragen nicht per PM.

"Alle sagten, das geht nicht! Dann kam einer, der wusste das nicht - und hat's gemacht!"

Funktioniert leider nicht.

Ich glaube auch nicht daran, dass es sich um ein Problem handelt, den SQL Server zu finden. Ich hab weil ich mir da nicht mehr sicher war mal aus dem Backslash einen Forwardslash gemacht, da kommt der Fehler, dass er den SQL Server nicht finden kann. Mit dem G63W26 sollte auch kein Problem darstellen, das ist der Netzwerkname des Servers, unter dem man den i.e. im Explorer auch findet.

Kann es vorkommen, dass es an mangelnden Rechten liegt? Ich hab bisher nicht die Gelegenheit bekommen die ganze Sache als Administrator zu testen, und das fertige Programm sollte ja auch keine Administratorberechtigungen brauchen nur um eine Datenbankverbindung herzustellen, aber ich sag mal, damit kenne ich mich am wenigsten aus und vermute deswegen, dass es irgendwas in die Richtung ist.

HI,

ich hab das Problem beim SQL Express,
daß dieser nicht erreichbar ist,
wenn der Dienst nicht nach Standart Installation mit Standart-Benutzern installiert wurde.
Ändere ich den Benutzer ab, startet der Dienst aber er ist eben nicht erreichbar.

MfG
Björn

Das Leben ist schön!

Wenn du mit dem Management Studio Express eine Verbindung bekommst, solltest Du es auch mit deiner SW bekommen, vorausgesetzt ihr benutzt die selben Credentials.

Ist das Management Studio auf der selben Kiste wie der SQL Express selber? Wenn ja, schau dir mal an, ob die TCP Verbindung für den SQL Server aktiviert sind. Diese sind nämlich IMHO beim Express per Default deaktiviert. Deswegen kommen die Clients nicht an den Server ran.

"Jedes Ding hat drei Seiten, eine positive, eine negative und eine komische." (Karl Valentin)