Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Transparentes Bild + schwarze Ränder + IE 8
progi123
myCSharp.de - Member

Avatar #avatar-3317.gif


Dabei seit:
Beiträge: 74
Herkunft: Süddeutschland

Themenstarter:

Transparentes Bild + schwarze Ränder + IE 8

beantworten | zitieren | melden

Hi,

ich hab bei diesem Bild den weißen äußeren Rand mit Paint.NET transparent gemacht (Zauberstab + Entf). Im IE 8 bekommt das Bild auf einmal schwarze Ränder, sowohl als png als auch als gif. Bei einem anderen Browser funktioniert es einwandfrei. Wie also könnte man die schwarzen Ränder entfernen?
private Nachricht | Beiträge des Benutzers
m0rius
myCSharp.de - Member

Avatar #avatar-3125.png


Dabei seit:
Beiträge: 1043

beantworten | zitieren | melden

Hallo progi123,

bei mir tritt das Problem nicht auf – das Bild wird auch im Internet Explorer 8 korrekt dargestellt.

m0rius
Attachments
Mein Blog: blog.mariusschulz.com
Hochwertige Malerarbeiten in Magdeburg und Umgebung: M'Decor, Ihr Maler für Magdeburg
private Nachricht | Beiträge des Benutzers
progi123
myCSharp.de - Member

Avatar #avatar-3317.gif


Dabei seit:
Beiträge: 74
Herkunft: Süddeutschland

Themenstarter:

beantworten | zitieren | melden

Hi,

wenn man sich den Link direkt anschaut ist ja alles in Ordnung. Das Problem tritt erst auf, wenn man das Bild bearbeitet. Ich hab den weißen Rand transparent gemacht, sodass nur ein rundes Schild übrig bleibt. Beim ersten laden sieht das Bild auch noch gut aus. Sobald man die Fenstergröße des IE verändert oder das Bild mit Hilfe von JavaScript bewegt, tauchen auf einmal schwarze Ränder auf.


edit: Hab testweise ein grünes Rechteck auf eine transparente Fläche gezeichnet. Dieses kriegt auch einen schwarzen Rand. Es liegt also nicht direkt am Bild. Könnte das JavaScript-Steuerelement, das zum Darstellen verwendet wird, dafür verantwortlich sein?
Dieser Beitrag wurde 4 mal editiert, zum letzten Mal von progi123 am .
private Nachricht | Beiträge des Benutzers
Peter Bucher
myCSharp.de - Experte

Avatar #jVxXe7MDBPAimxdX3em3.jpg


Dabei seit:
Beiträge: 6141
Herkunft: Zentralschweiz

beantworten | zitieren | melden

Hallo progi123

Bitte mehr Informationen und am besten ein "richtiges" Beispiel zum nachvollziehen des Problems.

Die Glaskugel habe ich leider im Amiland gelassen :-(


Gruss Peter
--
Microsoft MVP - Visual Developer ASP / ASP.NET, Switzerland 2007 - 2011

- https://peterbucher.ch/ - Meine persönliche Seite
- https://fpvspots.net/ - Spots für FPV Dronenflüge
private Nachricht | Beiträge des Benutzers
progi123
myCSharp.de - Member

Avatar #avatar-3317.gif


Dabei seit:
Beiträge: 74
Herkunft: Süddeutschland

Themenstarter:

beantworten | zitieren | melden

Morgen,

hat sich erledigt. Es ging darum einen Marker in OpenLayers anzulegen und diesen zu bewegen. Allerdings gibt es verschiedene Möglichkeiten das umzusetzen und mittlerweile hab ich die richtige gefunden.
private Nachricht | Beiträge des Benutzers