Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
problem mit user.config
Fabse
myCSharp.de - Member



Dabei seit:
Beiträge: 124

Themenstarter:

problem mit user.config

beantworten | zitieren | melden

ich nutze vs2005beta2 - c#

mein programm enthält 2 forms. die eine liest den benutzername ein und speichert ihn in der user config.
Properties.Settings mySettings = new EmuleLinkV2Client.Properties.Settings();
mySettings.präfix = präfixInput.Text;
mySettings.Save();

so und dann registriert es sich über einen tastendruck für ed2k://-links in der registry.

wenn ich das proggi normal aufrufe, kommt die form 1 und zeigt mir den gespeicherten namen an.

wenn ich auf einen ed2k-link im browser klicke, öffnet er mein app mit dem link als erstes argument. das programm öffnet jetzt form 2. diese liest jetzt den benutzernamen wieder ein aus der user.config.

das funktionert problemlos so.

aber jetzt kommts, wenn ich die gleiche anwendung über clickonce deploye und installiere, dann verhält sich form 1 nach wie vor genauso.

aber wenn das programm über einen link geöffnet wird, dann nutzt er die user.config nichtmehr und nimmt nur den standardnutzernamen aus der app.config!

das programm läuft unter full trust!

[edit]

bei neuem build mit neuer version und so, muss man doch normalerweise alle user.config sachen neu eingeben, weil er die vergisst. mir ist aber aufgefallen, dass er als nutzer immer Fabse hat und nicht unbekannt, wie in der app.config angegeben.

habe ich eigentlich überhaupt irgendwas falsch gemacht oder werkeln die da noch voll drann, dass Property.Settings endlich mal mit Clickonce geht ?? *arg*

ach ja und mit sign und nicht sign und so hab ich schon erfolglos rumexperiementiert ;(

---

War ne lange zeit nicht hier, aber hab in letzter zeit wieder begonnen mehr zu coden! das board war die ganze zeit auf meiner favorieten liste! (ich bin nicht fremd gegangen )
private Nachricht | Beiträge des Benutzers
Fabse
myCSharp.de - Member



Dabei seit:
Beiträge: 124

Themenstarter:

beantworten | zitieren | melden

kann keiner was dazu sagen?

ich hab noch bestimmt 2 stunden rumprobiert und hier und da gesucht im internet.

wenn keiner von euch mehr was weiß, muss ich mir meine eigene settingsverwaltung schreiben

bitte bitte 1 oder 2 möglichkeiten *fleh*
private Nachricht | Beiträge des Benutzers
DeveloperX
myCSharp.de - Member



Dabei seit:
Beiträge: 462
Herkunft: .at/ooe&stmk

beantworten | zitieren | melden

@Fabse:

Wie registriert man seine Applikation für "ed2k://" oder andere "Protokolle"?

mfg
private Nachricht | Beiträge des Benutzers