Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Silverlight für Firefox
UliA
myCSharp.de - Member



Dabei seit:
Beiträge: 25

Themenstarter:

Silverlight für Firefox

beantworten | zitieren | melden

hi,

wir denken darüber nach ein kundenportal auf silverlight basis umzusetzen. allerdings finde ich immer wieder seiten, die lediglich vom IE und nicht vom FF unterstützt werden. ein beispiel aus der showcase reihe von silverlight.net:

IA Information Systems AG

mit dem IE kann ich die seite aufrufen, beim ff sagt es mir, dass ich silverlight nicht installiert hätte, was aber natürlich nicht so ist (im IE läuft es ja). kann mir jemand sagen, woran das liegt?
the less code you need, the bigger...
private Nachricht | Beiträge des Benutzers
gfoidl
myCSharp.de - Team

Avatar #avatar-2894.jpg


Dabei seit:
Beiträge: 7547
Herkunft: Waidring

beantworten | zitieren | melden

Hallo,

Silverlight ist ein Browser-PlugIn. Es muss somit das PlugIn für jeden Browser separat installiert werden. Für FireFox gibt es das PlugIn auch schon.

Google gibt dabei über 1e6 Treffer aus.

mfG Gü
Stellt fachliche Fragen bitte im Forum, damit von den Antworten alle profitieren. Daher beantworte ich solche Fragen nicht per PM.

"Alle sagten, das geht nicht! Dann kam einer, der wusste das nicht - und hat's gemacht!"
private Nachricht | Beiträge des Benutzers
UliA
myCSharp.de - Member



Dabei seit:
Beiträge: 25

Themenstarter:

beantworten | zitieren | melden

Zitat von gfoidl
Hallo,

Silverlight ist ein Browser-PlugIn. Es muss somit das PlugIn für jeden Browser separat installiert werden. Für FireFox gibt es das PlugIn auch schon.

Google gibt dabei über 1e6 Treffer aus.

mfG Gü

hi, danke für die prompte antwort. dass es ein browser plugin ist, ist mir klar. ich bin mir aber relativ sicher, dass es nur eine setup datei (für windows) gibt, die das plugin für alle unterstützten browser installiert. selbst wenn dem nicht so wäre, habe ich mit dem FF die seite Check Page aufgerufen, die mir sagt:

The version of Silverlight installed is:
Silverlight 3 GDR 1 (3.0.40723.0)

You are ready to use Microsoft Silverlight



es liegt also imho an der eigentlichen anwendung der seite oder sehe ich das falsch?
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von UliA am .
the less code you need, the bigger...
private Nachricht | Beiträge des Benutzers
gfoidl
myCSharp.de - Team

Avatar #avatar-2894.jpg


Dabei seit:
Beiträge: 7547
Herkunft: Waidring

beantworten | zitieren | melden

Aha gut zu wissen. Ich hab damals das PlugIn für FF noch separat installiert.

Hast du irgenwelche NoScript oder sonstiges im FF welche das Ausführen des PlugIns behindern können?


mfG Gü
Stellt fachliche Fragen bitte im Forum, damit von den Antworten alle profitieren. Daher beantworte ich solche Fragen nicht per PM.

"Alle sagten, das geht nicht! Dann kam einer, der wusste das nicht - und hat's gemacht!"
private Nachricht | Beiträge des Benutzers
UliA
myCSharp.de - Member



Dabei seit:
Beiträge: 25

Themenstarter:

beantworten | zitieren | melden

Zitat von gfoidl
Aha gut zu wissen. Ich hab damals das PlugIn für FF noch separat installiert.

Hast du irgenwelche NoScript oder sonstiges im FF welche das Ausführen des PlugIns behindern können?


mfG Gü

ja, habe ich, aber 1. habe ich das komplett für diese seite deaktiviert und 2. wird nicht einfach nichts angezeigt, sondern es kommt die meldung, dass silverlight nicht auf dem system installiert ist.
the less code you need, the bigger...
private Nachricht | Beiträge des Benutzers
[email protected]
myCSharp.de - Member



Dabei seit:
Beiträge: 407

beantworten | zitieren | melden

Könnte es vielleicht sein, dass es ein Problem mit der Version gibt?

Die Checkpage von MS gibt ja an dass Du Silverlight 3 installiert hast und
es somit funktioniern müsste.

Was is aber nun wenn die Seite für Silverlight 2 erstellt ist?

[offtopic]
btw. übelster Technologiemissbrauch, das Design vor allem vom Menu
errinnert mir an Anfang 2000 - DHTML-Spielchen... ;)
[/offtopic]
private Nachricht | Beiträge des Benutzers
tom-essen
myCSharp.de - Experte

Avatar #avatar-2140.png


Dabei seit:
Beiträge: 1928
Herkunft: NRW

beantworten | zitieren | melden

Hallo!

Ich habe ein ähnliches Problem: Silverlight ist installiert, kann aber nicht verwendet werden, weil meine Hardware zu alt ist. Ich schätze mal, dass Silverlight aufgrund seiner Größe nur auf neueren Prozessoren läuft, welche bestimmte Befehle unterstützen.
Nobody is perfect. I'm sad, i'm not nobody
private Nachricht | Beiträge des Benutzers
Cookiie
myCSharp.de - Member

Avatar #avatar-2328.jpg


Dabei seit:
Beiträge: 364
Herkunft: früher Leipzig, jetzt Out of Rosenheim

beantworten | zitieren | melden

Hi,

also ich war grad mit dem aktuellen FF auf der Seite und es geht wunderbar.
Vista auf aktuellen Patchstand
Silverlight 3
Firefox 3.5

Liegt vielleicht an der Firefoxversion bzw. es gibt glaub ich auch nen spezielles plugin fürn firefox bezüglich der .net unterstützung. Vielleicht wird das ja auch benötigt.

Gruß Cookiie

btw.
die Seite überzeugt mich persönlich null, nette Spielerei, mehr aber auch nicht
"Hail to the King, Baby!"
private Nachricht | Beiträge des Benutzers
m0rius
myCSharp.de - Member

Avatar #avatar-3125.png


Dabei seit:
Beiträge: 1043

beantworten | zitieren | melden

Hallo UliA,

ich habe mir ebenfalls die verlinkte Seite im Firefox 3.5.1 angesehen und sie funktioniert.
Silverlight habe ich auch ohne Extra-Plugins installiert ...

Ich finde sie zwar potthässlich, aber das tut hier nichts zur Sache :P.

m0rius
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von m0rius am .
Mein Blog: blog.mariusschulz.com
Hochwertige Malerarbeiten in Magdeburg und Umgebung: M'Decor, Ihr Maler für Magdeburg
private Nachricht | Beiträge des Benutzers
pdelvo
myCSharp.de - Member

Avatar #avatar-3354.png


Dabei seit:
Beiträge: 1407

beantworten | zitieren | melden

Bei mir läuft sie. Ich hab kein NoScript oder so drauf.
Zitat
Ich finde sie zwar potthässlich, aber das tut hier nichts zur Sache :P.

Obwohl. Die Seitendarstellung hintereinander finde ich schick. Das Menu naja....


Gruß pdelvo
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von pdelvo am .
private Nachricht | Beiträge des Benutzers
UliA
myCSharp.de - Member



Dabei seit:
Beiträge: 25

Themenstarter:

beantworten | zitieren | melden

hi leute, danke für die infos. ich habe es mit win7 und vista auf aktuellem patchstand und ff 3.5.2 versucht. aber ich probiere es mal in meiner VM mit einer jungfräulichen FF installation. vielleicht liegt es an irgendeiner erweiterung.

zu frage, was passiert, wenn eine anwendung für silverlight 2 geschrieben wurde: soweit ich weiß, sollte silverlight immer abwärtskompatibel sein. allerdings hatte ich da auch schon ausnahmen. vielleicht weiß da jemand etwas konkreteres? aber ich werde mal schauen, ob ich dazu eine konkrete aussage finde.

zur frage mit der alten hardware: wie lautet denn der fehler genau. wenn es an der hardware liegen sollte, dann an der gpu, weil silverlight ab v3 diese intensiver nutzt (macht flash ja auch). des weiteren ist silverlight ja nur für betriebssysteme ≥ win2000 verfügbar (weiß allerdings nicht, ob das noch für die aktuelle version gilt oder ob hier winXP als mindestanforderung gilt). also wenn du xp und eine directx 9 fähige graka hast, sollte das eigentlich kein problem sein.
the less code you need, the bigger...
private Nachricht | Beiträge des Benutzers
UliA
myCSharp.de - Member



Dabei seit:
Beiträge: 25

Themenstarter:

beantworten | zitieren | melden

Hi Leute,

das Problem lag wohl darin, dass ich parallel das SDK und die End User Runtime installiert hatte. Nachdem ich das SDK deinstalliert hatte, ging es.

Interessanterweise konnte ich das Problem nicht reproduzieren. Aber die Infos kann ich schon mal für ein kleines FAQ verwenden, falls die Kunden dann ähnliche Probleme haben werden (unter anderem kann ich mir vorstellen, dass NoScript und Adblock durchaus bei einigen Probleme machen könnten)
the less code you need, the bigger...
private Nachricht | Beiträge des Benutzers