Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Form Designer zeigt Komponenten nicht mehr an
King-Malkav
myCSharp.de - Member

Avatar #avatar-2613.jpg


Dabei seit:
Beiträge: 266
Herkunft: Landau

Themenstarter:

Form Designer zeigt Komponenten nicht mehr an

beantworten | zitieren | melden

Hallo Community,

ich habe eine kleine Anwendung für unsere Firma geschrieben, getestet und bereitgestellt. Danach habe ich Visual Studio geschlossen.

Als ich heute morgen Visual Studio 2005 gestartet habe und mein Projekt geladen war das Form in Urzustand. Sämtliche Komponenten sind nicht mehr da, bzw. werden nicht angezeigt. Das Programm lässt sich aber ohne das der Debugger rummault ausführen.

Laut Visual Studio sind die Komponenten auch noch da, ich kann sie über das Drop Down Menü noch auswählen, nur sind sie nicht auf dem Form sichtbar.

Was ist hier passiert?

Betriebssystem ist Windows XP SP3 und alle Updates für Visual Studio sind gemacht. Ich hatte auch vorher noch nie Probleme damit.

Irgendwelche Ideen? Ich möchte ungern die Maske nochmal neu bauen müssen.

MFG
private Nachricht | Beiträge des Benutzers
Michbeck1983
myCSharp.de - Member

Avatar #avatar-2965.gif


Dabei seit:
Beiträge: 264
Herkunft: Augsburg

beantworten | zitieren | melden

Die Lösung für dieses Problem würde mich auch interessieren. Dieser Fall passiert mir oft, wenn ich ein Form mit einem Menü bzw. einem Toolstrip-Menü baue, in dem Grafiken für die Icons/Buttons dargestellt werden, und ich dann eines der Icons lösche bzw. den dazugehörigen Button entferne. Dann wird das komplette Menü nicht mehr dargestellt...
Neulich im Computerkurs:
Mein Computer kennt Else nicht!
[URL]XING-Profil[/URL]
private Nachricht | Beiträge des Benutzers
King-Malkav
myCSharp.de - Member

Avatar #avatar-2613.jpg


Dabei seit:
Beiträge: 266
Herkunft: Landau

Themenstarter:

beantworten | zitieren | melden

Also ich glaube ich habe die Lösung gefunden, sicher bin ich mir nicht.

Ich habe wohl das Icon für das Form gelöscht und dadurch hat es wohl mein Form zerschossen.

In der Designer Datei muss ich die Controlls neu binden, dann funzt es wieder. Doof ist nur das ich sämtliche Events der Controlls auch neu binden muss.

MFG
private Nachricht | Beiträge des Benutzers
Gelöschter Benutzer

beantworten | zitieren | melden

projekt bereinigen lassen oder auch mal zur not den "obj"-ordner löschen hilft in den allermeisten fällen, wenn man probleme mit dem designer hat.
san-software
myCSharp.de - Member



Dabei seit:
Beiträge: 96

beantworten | zitieren | melden

oft hilft es auch die suo-Datei zu löschen. Microsoft schafft es immer wieder, die inkonsistent zu machen
private Nachricht | Beiträge des Benutzers