Laden...

"Falsches" XML bei "korrekten" ConnectionString

Erstellt von f.ritz vor 16 Jahren Letzter Beitrag vor 16 Jahren 1.290 Views
f.ritz Themenstarter:in
341 Beiträge seit 2004
vor 16 Jahren
"Falsches" XML bei "korrekten" ConnectionString

SQL Server 2005 <bitte immer angeben>

Hallo zusammen,

ich habe ein kleines Konfigurationsproblem. In der web.config steht folgendes:

<add key="Table" value="Testtabelle & Test" />

Wobei "Testtabelle & Test" der Tabellenname ist, wegen den & ist die Konfigurationsdatei, für den XML-Parser, natürlich nicht lesbar. Weil dieser für den & den &amp; erwartet.
Wenn ich aber den & in den &amp; korregiere - mekkert der SQL-Server weil die Tabelle "Testtabelle &amp; Test" nicht kennt!

Wie kann man das Problem am besten lösen?

J
3.331 Beiträge seit 2006
vor 16 Jahren

Vorschlag: speichern mit "&amp;" und nach dem Einlesen String.Replace() anwenden.

Guten Rutsch! Jürgen

f.ritz Themenstarter:in
341 Beiträge seit 2004
vor 16 Jahren

Vorschlag: speichern mit "&amp;" und nach dem Einlesen String.Replace() anwenden.

Hab ich schon gemacht... Ich dachte nur man kann es iregendwie eleganter lösen...

M
402 Beiträge seit 2005
vor 16 Jahren

Hi!

Wie wärs mit einem "besseren" Tabellennamen?

lg

f.ritz Themenstarter:in
341 Beiträge seit 2004
vor 16 Jahren

Hi!
Wie wärs mit einem "besseren" Tabellennamen?
lg

....schön wärs.... würde aber noch mehr Arbeit verursachen....
Ich bleibe dann lieber bei dem String.Replace().

Danke &amp; schöne Feiertage!