Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
CSS wird nicht übernommen
f.ritz
myCSharp.de - Member

Avatar #avatar-2331.jpg


Dabei seit:
Beiträge: 341
Herkunft: Sibirien

Themenstarter:

CSS wird nicht übernommen

beantworten | zitieren | melden

Hallo!

Ich möchte auf meiner Seite einen Hintergrundbild laden. Die Definition mache ich in der CSS-Datei:
body
{
background-image: url('http://localhost/RedualPortal/img/background1.jpg');
background-position: center top;
background-repeat: no-repeat;
}


Die Einbindung auf der ASPX mache ich so:
<head runat="server">
<title>MySite</title>
<link rel="stylesheet" type="text/css" href="style.css" />
</head>


Das Problem dabei ist dass diser Hintergrund nur auf einer Seite nicht "gezogen" wird, aber auf allen anderen schon obwohl ich überall das gleiche Konstrukt habe! Dazu muss ich sagen dass im VS-Editor der Hintergrund auch dargestellt wird, nur nicht im Browser.

Woran klann es liegen?
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von f.ritz am .
private Nachricht | Beiträge des Benutzers
Profox
myCSharp.de - Member



Dabei seit:
Beiträge: 49
Herkunft: Schwarme bei Bremen

beantworten | zitieren | melden

Zitat
Die Einbindung auf der ASPX mache ich so:
 <head runat="server">
<title>MySite</title>
<link rel="stylesheet" type="text/css" href="style.css" />
</head>

Fehlt hinter "stylesheet" nicht ein ".css"?

--
Gruß
Profox.
--
mfG.
Marcel Eckhoff
private Nachricht | Beiträge des Benutzers
m0rius
myCSharp.de - Member

Avatar #avatar-3125.png


Dabei seit:
Beiträge: 1043

beantworten | zitieren | melden

Nein, da kommt normalerweise kein ".css" dahinter... Hast dus schonmal mit "background: ..." statt mit "background-image: ..." versucht? So funktioniert das zumindest bei mir...

lg,
m0rius
Mein Blog: blog.mariusschulz.com
Hochwertige Malerarbeiten in Magdeburg und Umgebung: M'Decor, Ihr Maler für Magdeburg
private Nachricht | Beiträge des Benutzers
Peter Bucher
myCSharp.de - Experte

Avatar #jVxXe7MDBPAimxdX3em3.jpg


Dabei seit:
Beiträge: 6141
Herkunft: Zentralschweiz

beantworten | zitieren | melden

Hallo zusammen

Die Anführungszeichen sind da fehl am Platz.
- http://www.css4you.de/background-image.html

Ich würde im Normalfall relative statt absoluter Links verwenden.


Gruss Peter
--
Microsoft MVP - Visual Developer ASP / ASP.NET, Switzerland 2007 - 2011

- https://peterbucher.ch/ - Meine persönliche Seite
- https://fpvspots.net/ - Spots für FPV Dronenflüge
private Nachricht | Beiträge des Benutzers