Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Verbindungsprobleme mit dem Server SQL 2005 Express
myBig?
myCSharp.de - Member



Dabei seit:
Beiträge: 241
Herkunft: Schleswig-Holstein

Themenstarter:

Verbindungsprobleme mit dem Server SQL 2005 Express

beantworten | zitieren | melden

Hi zusammen,

bekomme keine Verbindung zum SQL Server 2005 auf meinem Laptop.

Die Fehlermeldung lautet so:
Fehler beim Herstellen einer Verbindung mit dem Server. Beim Herstellen einer Verbindung mit dem SQL Server 2005 kann dieser Fehler dadurch verursacht werden, dass unter den SQL Server-Standardeinstellungen Remoteverbindungen nicht zulässig sind!

Habe mich schon über SQL-Authentifizierung angemeldet klappt troztdem nicht.


            try
            {
                SqlConnection con = new SqlConnection();
                con.ConnectionString = "Data Source=(local);" +
                                       "Database=MyCompany;" +
                                       "Trusted_Connection=false;" +
                                       "User ID=xxxx;" +
                                       "Password=xxxx;";
                con.Open();
            }
            catch (Exception e)
            {
                MessageBox.Show(e.Message);
            }

Kann mir vielleicht einer helfen, komme einfach nicht weiter?

Mfg
private Nachricht | Beiträge des Benutzers
onlinegurke
myCSharp.de - Member



Dabei seit:
Beiträge: 781
Herkunft: Dresdner in Karlsruhe

beantworten | zitieren | melden

Ersetz mal 'Database' mit 'Initial Catalog' und bei 'User ID' bin ich mir nicht sicher, ob das wirklich zusammen geschrieben wird.

Generell ist aber der Einsatz eines System.Data.SQLClient.SQLConnectionStringBuilder (oder wie auch immer der genau heißt) wärmstens zu empfehlen, dann passieren dir solche Sachen nicht!
private Nachricht | Beiträge des Benutzers
BerndFfm
myCSharp.de - Team

Avatar #nZo9Gyth4VPDSxGqM4sT.jpg


Dabei seit:
Beiträge: 3782
Herkunft: Frankfurt a.M.

beantworten | zitieren | melden

Hallo Big,

probier mal mit SQL Server Management Studio.

Ist es ein SQL Express Server ? Versuchst Du von einem anderen Rechner aus zuzugreifen ? Geht es lokal ?

Beim Express mit man das TCP/IP-Protokoll und einen Browser-Dienst extra einschalten.

Grüße Bernd
Workshop : Datenbanken mit ADO.NET
Xamarin Mobile App : Finderwille Einsatz App
Unternehmenssoftware : Quasar-3
private Nachricht | Beiträge des Benutzers
myBig?
myCSharp.de - Member



Dabei seit:
Beiträge: 241
Herkunft: Schleswig-Holstein

Themenstarter:

beantworten | zitieren | melden

Hi Bernd,

mit dem SQL Server Management Studio Express komme ich rauf bzw bekomme eine Verbindung.

Habe eine SQL Server 2005. Ich arbeite nur mit meinem Laptop, versuche also nicht von einem anderen Rechner drauf zugreifen. Weiß echt nicht woran es liegt. Muss auch dazu gestehen, dass ich mich nicht sehr gut mir SQL Server auskenne.

Wollte alles nur Lokal bearbeiten. Habe in der Datenbank MyCompany zwei Tabellen mit denen ich arbeiten wollte. Und nun bekomme ich keine Verbindung:-(

Wo stelle ich denn Browser- Dienst extra ein? Ich glaube ich habe schon alles aktiviert, bin fast alles durchgegangen und habe alles aktiviert. Ich hoffe ich habe nicht vergessen. Ich glaube das mit dem Browser- Dienst habe ich noch nicht

Gruß Olli(Big)
private Nachricht | Beiträge des Benutzers
Kantiran
myCSharp.de - Member



Dabei seit:
Beiträge: 71
Herkunft: CH

beantworten | zitieren | melden

http://www.connectionstrings.com/?carrier=sqlserver2005

Sieh dir die Connectionstrings an.
Anscheinend benutzt du ein Mix aus "Standard Security" und "Standard Security alternative syntax".
Keine Ahnung ob das so geht.

Gruss Fellmer
private Nachricht | Beiträge des Benutzers
myBig?
myCSharp.de - Member



Dabei seit:
Beiträge: 241
Herkunft: Schleswig-Holstein

Themenstarter:

beantworten | zitieren | melden

Hi zusammen nochmal,

habe jetzt eine Verbindung hinbekommen. Hatte wohl doch den SQLExpress Server, sorry:-(!
Habe jetzt

server=.\\SQLExpress 
angegeben. Nun klappts.

Danke an alles für die hilfe

Gruß Olli
private Nachricht | Beiträge des Benutzers