Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
SharpDevelop und .NET Compact Framework
Systemfehler
myCSharp.de - Member



Dabei seit:
Beiträge: 13

Themenstarter:

SharpDevelop und .NET Compact Framework

beantworten | zitieren | melden

Wie kann man mit SharpDevelop Anwendungen für PPCs entwickeln ?(

Wenn ich ein neues Projekt (CompactFramework / Windows Anwendung) erstelle und dann auf "Erstelle Solution" klicke, bekomme ich folgene Fehlermeldung:
Zitat
Dieses Projekt erfordert .NET Compact Framework CF 2.0. Dieses Programm ist jedoch auf dem Computer nicht installiert. - C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.CompactFramework.Common.targets:23,9

Installierte Anwendungen:
  • SharpDevelop (Version: 2.1.0 Build: 1825)
  • Microsoft .NET Compact Framework 2.0 SP1
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 1.1 German Language Pack
  • Microsoft .NET Framework 2.0
  • Microsoft .NET Framework 2.0 Language Pack - DEU
  • Microsoft .NET Framework 2.0 SDK - DEU
  • Microsoft .NET Framework SDK (German) 1.1
private Nachricht | Beiträge des Benutzers
lex
myCSharp.de - Member



Dabei seit:
Beiträge: 113
Herkunft: Niedersachsen

beantworten | zitieren | melden

hast du vielleicht nur das SP1 des Compact Frameworks installiert?
Würde das CF einfach noch mal neu installieren und später das SP1 dazu!
private Nachricht | Beiträge des Benutzers
Systemfehler
myCSharp.de - Member



Dabei seit:
Beiträge: 13

Themenstarter:

beantworten | zitieren | melden

Ich hatte das CF 2.0 schon mal installiert. Da hat es alllerdings auch nicht funktiontioniert. Allerdings ist mir nicht ganz klar, wo das CF überhaupt installiert wurde. Ich kann es nämlich nirgends finden.
Ich habe irgendwo auch gelesen, das man irgendwelche Dateien vom CF umbennenen muss und dann in einen bestimmten Ordner packen muss.
private Nachricht | Beiträge des Benutzers
Systemfehler
myCSharp.de - Member



Dabei seit:
Beiträge: 13

Themenstarter:

beantworten | zitieren | melden

Weiß den niemand Rat?

In der Hilfe von SharpDevelop steht nur folgendes:
Zitat
Sharp Develop 2.1 CF Development
Sharpdevelop 2.1 has much improved support for the compact framework. You should simply install the .NET 2.0 SDK, create a new Compact Framework project and begin development

TODO Flesh out this section a little more.
Das CF ist hier installiert: C:\Programme\microsoft.net\sdk\CompactFramework\v2.0

In der Fehlermeldung steht allerdings , dass im folgenden Ordner die folgende Datei fehlt:
Ordner: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\
Datei: Microsoft.CompactFramework.Common.targets

Muss ich vielleicht noch irgendwas kopieren oder installieren?

Ich habe das CF 2 Sp1 nochmal deinstalliert und das CF 2.0 installiert. Allerdings ist das Problem nicht behoben worden.
private Nachricht | Beiträge des Benutzers
MarsStein
myCSharp.de - Experte

Avatar #avatar-3191.gif


Dabei seit:
Beiträge: 3.170
Herkunft: Trier -> München

beantworten | zitieren | melden

Hallo,
ich vermute irgendetwas ist an Deiner .NET Framework 2.0 Installation korrupt:
Bei mir ist definitiv kein CF installiert. Aber diese Datei "Microsoft.CompactFramework.Common.targets" ist trotzdem an Ihrem Platz, gehört also zum Nicht-Compact-Framework.
Non quia difficilia sunt, non audemus, sed quia non audemus, difficilia sunt! - Seneca
private Nachricht | Beiträge des Benutzers
Systemfehler
myCSharp.de - Member



Dabei seit:
Beiträge: 13

Themenstarter:

beantworten | zitieren | melden

Das Problem liegt bei SharpDevelop, da muss man noch irgendetwas verändern. Ich habe Build 1852 heruntergeladen, das hat allerdings keine Abhilfe geschaffen.
Hat schon irgend jemand mit SharpDevelop für das CF programmiert? Es wäre schön wenn, er mal beschreiben könnte was er genau gemacht hat. Ich kann mit das Problem nämlich nicht erklären. Das .Net Framework 2.0 habe ich neu installiert, allerdings kommt immer noch der gleiche Fehler.
private Nachricht | Beiträge des Benutzers
MarsStein
myCSharp.de - Experte

Avatar #avatar-3191.gif


Dabei seit:
Beiträge: 3.170
Herkunft: Trier -> München

beantworten | zitieren | melden

Hallo,
vielleicht hilft Dir das hier weiter:
http://wiki.sharpdevelop.net/default.aspx/SharpDevelop.PocketPCs

EDIT: Da gehts un CF 1.0, sry
Non quia difficilia sunt, non audemus, sed quia non audemus, difficilia sunt! - Seneca
private Nachricht | Beiträge des Benutzers
MarsStein
myCSharp.de - Experte

Avatar #avatar-3191.gif


Dabei seit:
Beiträge: 3.170
Herkunft: Trier -> München

beantworten | zitieren | melden

Hallo,
diesmal der richtige:
http://wiki.sharpdevelop.net/default.aspx/SharpDevelop.CompactFramework2Development

EDIT:
Du kannst mal schauen was im mittleren Teil der Seite über das Verändern der Projektdatei usw. gesagt wird, und das mit den generierten Projektdateien vergleichen, vielleicht gibtsja da noch einen Bug...
Non quia difficilia sunt, non audemus, sed quia non audemus, difficilia sunt! - Seneca
private Nachricht | Beiträge des Benutzers
Systemfehler
myCSharp.de - Member



Dabei seit:
Beiträge: 13

Themenstarter:

beantworten | zitieren | melden

http://bugtracker.sharpdevelop.net/issue/ViewIssue.aspx?ID=1094
private Nachricht | Beiträge des Benutzers