Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Verschiedene Frameworks auf einem System?!
Vassili
myCSharp.de - Member

Avatar #avatar-2291.jpg


Dabei seit:
Beiträge: 187
Herkunft: Essen

Themenstarter:

Verschiedene Frameworks auf einem System?!

beantworten | zitieren | melden

Hallo leutz,

ich hab mich heut mal an den pc gesetzt um unnötige software zu deinstallieren und bemerkt, dass ich das compactframework 1.0 und 2.0 ebenso das Framework 1.1 und 2.0 mit den jeweiligen lng packs.

Macht es sinn beides drauf zu haben? oder kann ich die alten deinstallieren?
private Nachricht | Beiträge des Benutzers
jan223
myCSharp.de - Member

Avatar #avatar-2059.png


Dabei seit:
Beiträge: 460
Herkunft: Bocholt / NRW

beantworten | zitieren | melden

Wenn du nur das FW 2.0 hast kannst du keine Programme ausführen die das FW 1.1 benötigen, und umgekehrt natürlich.
private Nachricht | Beiträge des Benutzers
herbivore
myCSharp.de - Experte

Avatar #avatar-2627.gif


Dabei seit:
Beiträge: 49.486
Herkunft: Berlin

beantworten | zitieren | melden

Hallo jan223,

die Frameworks sind schon weitestgehend ab- und aufwärskompatibel. 1.1 Programm auf 2.0 ausführen sollte problemlos gehen, auch wenn man ggf. einen app.config verwenden muss. Für die umgekehrte Richtung gibt es verschiedene Aussagen: Siehe z.B. die Beiträge z.B. Vs2005 -Vs2003 dot.net 1.1 - 2.0 und Ein mit .NET 2.0 FW entwickeltes Programm unter .NET 1.1 . Wobei beide Threads insgesamt ganz interssant sind.

herbivore
private Nachricht | Beiträge des Benutzers
der Marcel
myCSharp.de - Member

Avatar #avatar-1860.gif


Dabei seit:
Beiträge: 564
Herkunft: Dresden

beantworten | zitieren | melden

Hallo herbivore!

Mir sind allerdings Fälle bekannt, indem es nicht gelingt Net1.1 Programme mit dem 2.0 Framework laufen zu lassen. Dies betrifft den Grafikkartentreiber von ATI.

der Marcel
:] :DDer größte Fehler eines modernen Computers sitzt meist davor :]
private Nachricht | Beiträge des Benutzers
Vassili
myCSharp.de - Member

Avatar #avatar-2291.jpg


Dabei seit:
Beiträge: 187
Herkunft: Essen

Themenstarter:

beantworten | zitieren | melden

Also kurz gefasst. 2.0 unterstützt in der Regel alle 1.1 Programme (Außnahmen bestätigen aber die Regel) von 2.0 zu 1.1 wird es etwas riskant sobald ein teil des 2.0 framework verwendet wird, das nicht in 1.1 vorhanden ist.

Dann lass ich erstmal noch beides drauf für ein Jahr oder so
private Nachricht | Beiträge des Benutzers