Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Framework Versionen
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

Framework Versionen

beantworten | zitieren | melden

Hallo allerseits!

Wollte mal nachfragen, wenn ich das aktuelle Framework Version 1.1 installiere, kann ich dann trotzdem mit dem alten Visual Studio .NET weiter entwickeln? Oder gibt es dort einige Probleme?

Danke + Gruß
Olaf
private Nachricht | Beiträge des Benutzers
cdr
myCSharp.de - Member



Dabei seit:
Beiträge: 1008
Herkunft: Zürich

beantworten | zitieren | melden

Stichwort Versioning:

Ich hab bei mir das VS.NET 2002 EA mit dem 1.0er und das VS.NET 2003 EA mit dem 1.1er Framework parallel am laufen, funktioniert bestens! Man kann auch beide gleichzeitig starten etc ...
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

ja da geb ich dir recht, das macht wirklich keine Probleme.
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
cdr
myCSharp.de - Member



Dabei seit:
Beiträge: 1008
Herkunft: Zürich

beantworten | zitieren | melden

btw: das alte VS.NET arbeitet nur mit dem 1.0er zusammen, will heissen deine Apps werden weiter mit dem alten Framework verlinkt, auch wenn zusätzlich das 1.1er installiert ist.
private Nachricht | Beiträge des Benutzers
public_override
myCSharp.de - Member



Dabei seit:
Beiträge: 32
Herkunft: the playgrid

beantworten | zitieren | melden

ich denke, auch das es unproblematisch ist, da ja die framework-versionen backwards-compatible bleiben müssen, und der kompiler mit dem framework distributiert wird, würde bei einem update nur die entwicklungs-ide die alte bleiben.
ich hasse freizeit,... sinniert man doch nur über dinge die man tun könnte, hätte man mehr freizeit
private Nachricht | Beiträge des Benutzers
Flamesword
myCSharp.de - Member



Dabei seit:
Beiträge: 108
Herkunft: Langenselbold.net

beantworten | zitieren | melden

Du kannst dein altes VS .net bis zum 30.09 updaten.
www.mono-projekt.de - Die erste Deutschsprachige Mono-Community
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

nun habe ich version 1.1

beantworten | zitieren | melden

aber irgendwie ist das nicht in der registry registriert, so dass es garnicht da ist, obwohl ich es installiert habe.

habe mir die freie c# ide csharpdevelope gezogen und wollte die mal testen, weil sie in der ct sehr gut abgeschnitten hat.
aber irgendwie will das sdk1.1 nicht, muss ich da evtl. etwas beachten, wenn ich sdk1.0 und sdk1.1 nebeneinander herlaufen lassen will?

danke euch
Olaf
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

also das sharp develop läuft glaub ich nru mit 1.1 (also die neuste sharp develop version)... aber ich hatte mit sharp develop noch nie probleme ...mmhhh äußert komisch
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

installation sdk1.1 erfolgt ohne probleme, aber dann meckert das setup von csharpdevelope rum, dass kein sdk1.1 da ist, obwohl ich das vorher installiert habe :-(.

ich bin verzweifelt ....
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

ahh ich hab ne idee, vielleicht mekert er deswegen rum weils vielleicht die falsche sprache ist?? also vom framework
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

evtl sollte ich dann wohl mal die englische nehmen ;-). werde ich mal testen, dank dir.
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

so nun hab ichs, aber es funtzt immer noch nicht.

das sdk1.1 installiert nur die doofe doku und nicht das sdk an sich.
irgendwie glaubt die installationsroutine, dass ein sdk1.1 schon vorhanden ist, obwohl es das sdk1.0 ist :-(.

wiess jemand rat? (bitte keine win neuinstallation)

danke
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

mhh deinstalliert alles was mit dem framework zu tun hat, machn neustart und dann installierst das 1.1 nochmals ... vielleicht gehts dann (bzw saug von ms die neuste framework version nochmals...) dann müsste es eigentlich gehn
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
hauptmann
myCSharp.de - Member



Dabei seit:
Beiträge: 771
Herkunft: Österreich/Kärnten

beantworten | zitieren | melden

geh mal auf Start -> Ausführen -> msiexec

du brauchst wahrscheinlich version 2.0 des MS Installers(MSI) für sd
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

Zitat
Original von Hauptmann

geh mal auf Start -> Ausführen -> msiexec

du brauchst wahrscheinlich version 2.0 des MS Installers(MSI) für sd

aha, aber leider habe ich die version 2.00.2600.1106 - ist das nun gut oder schlecht?
private Nachricht | Beiträge des Benutzers
hauptmann
myCSharp.de - Member



Dabei seit:
Beiträge: 771
Herkunft: Österreich/Kärnten

beantworten | zitieren | melden

sollte reichen
hab aber k.A. warum es nicht geht

es könnte sein das das 1.0 Framework den GAC beansprucht
deinstallier mal das 1.0 Framework sodass du nur mehr das 1.1 drauf hast
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

das hab ich ja auch schon vorgeschlagen.
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

Zitat
Original von alexander

das hab ich ja auch schon vorgeschlagen.
sorry, das hatte ich leider nicht verstanden mit der version des installers.

so ich denke, das reicht nun auch.
wenn ich mein windows mal neu mache, werde ich beides testen.
vorher bleibt alles beim alten.

never change a running system :?

vielen dank für eure hilfe, wobei ich immer noch nicht weiss, was ein GAC ist :shock:
private Nachricht | Beiträge des Benutzers
hauptmann
myCSharp.de - Member



Dabei seit:
Beiträge: 771
Herkunft: Österreich/Kärnten

beantworten | zitieren | melden

na
du deinstallierst das .net Framework 1.0
was ist daran eine Veränderung des alten Systems

mit so einer einstellung wirst du nie weit kommen
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

na grundsätzlich find ich die einstellung "never change a running system" gut, aber du deinstallierst nur 1 programm, da wird nix schief geehn
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

bei meinem glück funtzt visual studio danach nicht mehr.

ich kenn das, da macht man mal auf die schnelle etwas und puff...... alles in die grütze gefahren und man könnte diese müllkiste von pc unter den nächsten lkw werfen, damit man sich damit nicht mehr rumärgern muss.

nein nein, ich lass das lieber und warte darauf, dass sich das system von alleine in die grütze fährt und ich von vorne anfangen kann
private Nachricht | Beiträge des Benutzers
hauptmann
myCSharp.de - Member



Dabei seit:
Beiträge: 771
Herkunft: Österreich/Kärnten

beantworten | zitieren | melden

:roll:

keine sehr gute Einstellung

ich versichere dir
bei der Deinstallation vom 1.0 kann nichts passieren

im schlimmsten Fall installierst du 1.0 wieder rauf

du darfst nicht so pessimistisch denken
private Nachricht | Beiträge des Benutzers
alexander
myCSharp.de - Member

Avatar #avatar-1566.gif


Dabei seit:
Beiträge: 2324
Herkunft: Wendlingen (Stuttgart)

beantworten | zitieren | melden

@ Olaf D

Ich hätte da ne Idee, mein Vater machts immer so, der macht regelmäßig von seinem PC Images (mit Drive Image oder wie das programm heisst). Das Programm macht ein abbild deiner Festplatte bzw. von deinem Windows und falls du durch irgendwas dein Windows zerschiesen solltest, spielst das Image wieder ein und alles ist wieder ok
Viele Grüße
Alexander
private Nachricht | Beiträge des Benutzers
Olaf D
myCSharp.de - Member



Dabei seit:
Beiträge: 18

Themenstarter:

beantworten | zitieren | melden

hab ich auch, aber leider habe ich neue hardware eingebaut, so dass es nichts mehr taugt. wenn das mainboard abraucht, dann bringt so ein image auch nichts :D.
private Nachricht | Beiträge des Benutzers