Laden...

MAUI-App für SAMSUNG GGalaxy S21U

Erstellt von visionmaster vor einem Jahr Letzter Beitrag vor einem Jahr 977 Views
V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr
MAUI-App für SAMSUNG GGalaxy S21U

Hallo zusammen,
ich versuche gerade, mich mit MAUI etwas näher zu beschäftigen. Ich verwende das mit VS2022 und C#.
Eine erste einfache App funktioniert auf dem Simulator bereits.
Aber ich bekomme es einfach nicht hin, die .apk auf dem Handy zu installieren. Es kommt jeweils beim Installationsversuch die Mitteilung, dass diese App nicht zu diesem Handy passt.
Kann mir evtl. jemand sagen, welche Einstellungen (wohl im Android SDK...?) ich vornehmen muss, dass es zu o.g. Handy passt?

Schon mal vielen Dank!

16.835 Beiträge seit 2008
vor einem Jahr

Es ist für potentiell Helfende immer besser, wenn Du die genaue Fehlermeldung nennst.
Siehe auch [Hinweis] Wie poste ich richtig?
Du suchst nach Hilfe, dann machs möglich einfach, dass Dir auch geholfen werden kann.

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Ja klar:
Sie lautet: "Die App wurde nicht installiert, da sie nicht mit deinem Smartphone kompatibel ist."
Aber auf was muss ich achten bzw. einstellen, dass sie kompatibel ist?

Hinweis von Abt vor einem Jahr

.. und bitte keine Full Quotes.

4.939 Beiträge seit 2008
vor einem Jahr

Welche Android-Version ist denn auf dem Handy installiert?
Hast du (bzw. Ist) evtl. die "MinSdkVersion" bei dem App-Projekt zu hoch eingestellt? s.a. Picking your compileSdkVersion, minSdkVersion, and targetSdkVersion.

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Es ist ein Galaxy S21 Ultra 5G mit Android 12 (UI-Version 4.1), letztes update vom 1.08.22

4.939 Beiträge seit 2008
vor einem Jahr

Dann überprüfe mal die Android-Einstellungen bei dem Projekt (ich weiß jetzt nicht genau, wo diese bei einem MAUI Projekt zu finden sind - sollten aber einfach zu finden sein).

3.825 Beiträge seit 2006
vor einem Jahr

Das Handy muss im Entwicklermode sein und über USB angeschlossen sein. USB Debugging sollte eingeschaltet sein.

Dann kann man es in VS als Ziel angeben, mit F5 wird die App dann direkt auf dem Handy geöffnet.

Mit ADB kann man es auch über WLAN ansprechen ohne USB.


"C:\Program Files (x86)\Android\android-sdk\platform-tools\adb.exe" connect 212.223.10.34:5555

Grüße Bernd

Workshop : Datenbanken mit ADO.NET
Xamarin Mobile App : Finderwille Einsatz App
Unternehmenssoftware : Quasar-3

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Vielen Dank für den Tipp.
Aber ich habe einfach keine chance, das Handy als Ziel anzugeben. Ich habe auch schon im Web gesucht. Aber es hilft nichts. Das gerät ist in VS einfach nicht existent. Auch im Gerätemanager für Android sollte doch ein Samsung aufgeführt sein. Da gibt es aber nur Nexus-Geräte. Hast du da noch einen Tipp?

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Hast du denn überhaupt schon
>
befolgt (davon war ich bisher ausgegangen)?

Ja - selbstverständlich.
USB-Debugging ist aktiv und ich sehe das Handy auch auf dem PC. Nur eben nicht im VS...

16.835 Beiträge seit 2008
vor einem Jahr

Hör doch bitte mal mit den ständigen Full quoted auf.
Niemand hat Lust jeden deiner Beiträge editieren zu müssen….
Danke.

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Zu Befehl!😉

4.939 Beiträge seit 2008
vor einem Jahr

Auch nicht nach einem Neustart vom VS?

Edit: Hast du denn den Samsung Android USB Driver for Windows schon installiert (der Google Driver ist nur für Nexus Geräte)?

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Das SAMSUNG-Driver war bereits installiert. Ich habe ihn nochmal neu installiert und alles nochmal runter- und wieder hochgefahren.
Keine Chance!
Müsste man die SAMSUNG-Geräte (also z.B. die Galaxy S-Serie) im Gerätemanager denn nicht eigentlich auch sehen?

Und mir ist auch nicht klar, warum man offensichtlich wirklich für jedes Android-Gerät eine separate Einstellung braucht.

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Ich habe mal eine simple App mit XAMARIN erstellt. Die lässt sich auf dem handy zumindest installieren (stürzt dann allerdings auch sofort wieder ab).
Aber der Gerätetyp im Gerätemanager bleibt unbekannt...

4.939 Beiträge seit 2008
vor einem Jahr

Wenn du des englischen einigermaßen mächtig bist, dann versuche mal die Hinweise in Visual Studio and Android Device Monitor doesn't detect any devices.
Prüfe mal besonders mit dem Konsolenkommando: adb devices.

V
visionmaster Themenstarter:in
77 Beiträge seit 2009
vor einem Jahr

Es läuft!!🙂
Fragt bitte nicht warum!
adb zeigte, dass das handy erkannt wurde, aber nicht autorisiert ist.
Darauf (nach weiteren Hinweisen im Netz) habe ich den debug-Modus deaktiviert, adbkey und adbkey.pub im .android-Verzeichnis (mehrfach) gelöscht, edb-Server gestoppt und wieder aktiviert...
...irgendwann ging es.
Im Android-Geräte-Manager gibt es das Gerät zwar immer noch nicht, aber beim debug-start wird es erkannt.
Ich bin gespannt, ob das eine stabile Lösung ist...

Vielen dank erstmal an dieser Stelle für die vielen Tipps. Ohne die wäre ich wohl nicht weiter gekommen.

4.939 Beiträge seit 2008
vor einem Jahr

🙂

Wenn nächsten Monat das offizielle .NET 7 herauskommt, dann werde ich auch mal ein MAUI-Projekt anfangen (daher hatte ich mich schon ein bißchen dort eingelesen).

T
708 Beiträge seit 2008
vor einem Jahr

Im Android-Geräte-Manager gibt es das Gerät zwar immer noch nicht, aber beim debug-start wird es erkannt.

Der Gerätemanager zeigt doch nur die Emulatoren an. Deshalb auch ausschließlich die Nexus/Pixel Geräte von Google selbst.
Das per USB verbundene Handy sehe ich nur in der Dropdown Liste, neben dem "Debuggen"-Knopf.