Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Sammelthema Wünsche und Bugreports myCSharp
Palladin007
myCSharp.de - Member

Avatar #avatar-4140.png


Dabei seit:
Beiträge: 1427
Herkunft: Düsseldorf

beantworten | zitieren | melden

Dann habe ich nichts gesagt
private Nachricht | Beiträge des Benutzers
Palladin007
myCSharp.de - Member

Avatar #avatar-4140.png


Dabei seit:
Beiträge: 1427
Herkunft: Düsseldorf

beantworten | zitieren | melden

Noch zwei Kleinigkeiten:

Wenn ich ein Thema erstelle, wird scheinbar das Forum als ungelesen markiert - was unsinnig ist, da ich das Thema ja erstellt habe.

Wenn ich beim Erstellen eines Beitrags den Fokus in die TextBox für die Überschrift setze und TAB drücke, navigiert er durch die Toolbar-Buttons, erwartet hätte ich persönlich aber, dass er in die TextBox für die Nachricht springt.

Aber wie gesagt: Nur Kleinigkeiten.
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 15618
Herkunft: BW

Themenstarter:

beantworten | zitieren | melden

Zitat von Palladin007
Wenn ich ein Thema erstelle, wird scheinbar das Forum als ungelesen markiert - was unsinnig ist, da ich das Thema ja erstellt habe.
Ja, liegt wie bereits gesagt am Verhalten, das auf Seite 2 beschrieben ist.
Wir suchen aktuell SQL-seitige Möglichkeiten, um die Abfrage zu optimieren, sodass der Gelesen-Status des Boards hier keine Rolle mehr spielt, den ja nun doch einige kritisieren.
Zitat von Palladin007
Wenn ich beim Erstellen eines Beitrags den Fokus in die TextBox für die Überschrift setze und TAB drücke, navigiert er durch die Toolbar-Buttons, erwartet hätte ich persönlich aber, dass er in die TextBox für die Nachricht springt.
Ja, Geschmackssache. Aktuell ist es einfach die Reihenfolge der Elemente.
Wir könnten natürlich die Buttons ausnehmen...


private Nachricht | Beiträge des Benutzers
Wilfried
myCSharp.de - Member

Avatar #2TnJ7IKlYXgOor5sZSIA.jpg


Dabei seit:
Beiträge: 86
Herkunft: Radeberg

beantworten | zitieren | melden

Hallo Abt,
den Beitrag Wie programmier ich einen Button in WinForms? hast du wohl geschlossen. Leider sieht man das nicht. Der Button "Antwort erstellen" wird weiterhin angezeigt. Wenn ich ihn drücke, dann wird der Fehler 403 angezeigt. Soll das so sein?
-Wer lesen kann, ist klar im Vorteil
-Meistens sitzt der Fehler vorm Monitor
-"Geht nicht" ist keine Fehlermeldung !

GidF
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 15618
Herkunft: BW

Themenstarter:

beantworten | zitieren | melden

Ist mir auch aufgefallen; hab ich schon als Bug übernommen.
Danke Dir.
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 15618
Herkunft: BW

Themenstarter:

beantworten | zitieren | melden

Zum Thema Board-Content-Gelesen-Status: wir haben nun eine Möglichkeit gefunden zu ermitteln, welcher Inhalt eines Boards noch nicht gelesen wurde, und das just-in-time.
Wir werden das in den nächsten Tagen implementieren und testen - aber Lösung ist in Aussicht :-)
private Nachricht | Beiträge des Benutzers
Wilfried
myCSharp.de - Member

Avatar #2TnJ7IKlYXgOor5sZSIA.jpg


Dabei seit:
Beiträge: 86
Herkunft: Radeberg

beantworten | zitieren | melden

Super
-Wer lesen kann, ist klar im Vorteil
-Meistens sitzt der Fehler vorm Monitor
-"Geht nicht" ist keine Fehlermeldung !

GidF
private Nachricht | Beiträge des Benutzers
BhaaL
myCSharp.de - Member

Avatar #erP6yAFiewXrJTqrvg6R.jpg


Dabei seit:
Beiträge: 653

beantworten | zitieren | melden

Hm, ich bin mir nicht ganz sicher ob das so sein sollte, aber ich musste mich vorhin wieder neu anmelden. In den Sessions sind jetzt 2 drin - meine aktuelle Session und eine alte, die zumindest laut den Datumswerten noch gültig sein sollte.
Ich war zuletzt am 1.4. hier, was etwa 5 Tage ohne Aktivität wären. Leider hab ich nicht dran gedacht, mir die Cookies anzusehen bevor ich mich angemeldet habe, drum kann ich net sagen ob hier eventuell was abgelaufen war.
Attachments
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 15618
Herkunft: BW

Themenstarter:

beantworten | zitieren | melden

Sieht alles nach Client-seitigem Thema aus.
Session hat sich ja offenbar laut Bild so verlängert, wie es sein sollte ;-)
private Nachricht | Beiträge des Benutzers
BhaaL
myCSharp.de - Member

Avatar #erP6yAFiewXrJTqrvg6R.jpg


Dabei seit:
Beiträge: 653

beantworten | zitieren | melden

Zitat von Abt
Sieht alles nach Client-seitigem Thema aus.

Irgendwas, worauf ich achten sollte, falls das nochmal vorkommt? Vermutlich Cookie Expiry date? Alles andere da drin sieht mir nach compressed und/oder encrypted payload aus; zumindest bekomm ich keinen sinnvollen plain-text raus (was sicher auch gut so ist).

Was mir auf die schnelle nur auffällt: Ich hab 5 Cookies (.AspNetCore.Antiforgery.[hash], .AspNetCore.Mvc.CookieTempDataProvider .MyCSharp.Identity, __cfduid und _ga).
Die ersten beiden sind Session Cookies (und daher vermutlich irrelevant), das .MyCSharp.Identity Cookie gilt eine Woche (also bis 13.4.2021), aber das __cfduid Cookie "nur" 5 Tage (also bis 11.4.2021) - und das _ga Cookie ein Jahr (also bis 13.4.2022, klingt dem Namen nach aber eher nach Google Analytics)
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 15618
Herkunft: BW

Themenstarter:

beantworten | zitieren | melden

.AspNetCore.Antiforgery -> wird zum CSRF Schutz von ASP.NET verwendet; also nur da, wo Formular-Informationen verarbeitet werden (Login, Register, Posts..)
.AspNetCore.Mvc.CookieTempDataProvider -> Standard-Store von ASP.NET; verwenden wir nicht
.MyCSharp.Identity -> beinhaltet die Identitätsinfos der Auth-Pipeline für ASP.NET Identity; gibts nur wenn Du angemeldet bist.
__cfdui -> CloudFlare Loadbalancing. Wird bald nicht mehr gesetzt, siehe Deprecating the __cfduid cookie. Entfällt aber ohnehin, wenn wir von CloudFlare auf Azure Frontdoor wechseln, sollte das früher sein als die Entfernung von CF.
_ga -> muss sehr alt sein, weil wir seit Mitte Januar kein Google Analytics mehr haben (bzw. wir generell keinerlei User Tracking verwenden); finde den Cookie bei mir auch nirgends. Kann daher nur mutmaßen, dass das das alte Google Analytics war.

Weitere Token, die kommen können:
- Botschutz von Google Captcha
- Two Factor Auth-Check von ASP.NET Identity

Also alles Cookies, die Betriebsrelevant sind.
Wir haben nicht einen einzigen optionalen oder trackenden Cookie.
Zitat
Vermutlich Cookie Expiry date?
Ja.
private Nachricht | Beiträge des Benutzers
BhaaL
myCSharp.de - Member

Avatar #erP6yAFiewXrJTqrvg6R.jpg


Dabei seit:
Beiträge: 653

beantworten | zitieren | melden

Zitat von Abt
Also alles Cookies, die Betriebsrelevant sind.
Wir haben nicht einen einzigen optionalen oder trackenden Cookie.
Und das ist auch gut so (side-note: ich konnte den Smiley hier nur eintippen, beim Klick im Smiley Menü der Toolbar passiert nix; andere Buttons funktionieren, als ob der Klick erst vom Flyout gefangen/geschluckt werden würde anstatt vom jeweiligen Smiley Button - wäre net überrascht wenn das nur im Firefox passiert)

Hab den _ga mal gekübelt, schwupp, kommt auch nicht mehr wieder. __cfdui schon, aber das war zu erwarten.
Zitat von Abt
Zitat
Vermutlich Cookie Expiry date?
Ja.
Will do, falls/sobald mir das nochmal auffällt.

private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 15618
Herkunft: BW

Themenstarter:

beantworten | zitieren | melden

Zitat von BhaaL
side-note: ich konnte den Smiley hier nur eintippen, beim Klick im Smiley Menü der Toolbar passiert nix

Dann hast Du einen Ad / Script Blocker, siehe myCSharp wechselt die Plattform
Steht auch im Startbeitrag dieses Themas unter Hinweise.
private Nachricht | Beiträge des Benutzers
BhaaL
myCSharp.de - Member

Avatar #erP6yAFiewXrJTqrvg6R.jpg


Dabei seit:
Beiträge: 653

beantworten | zitieren | melden

Zitat von Abt
Dann hast Du einen Ad / Script Blocker, siehe myCSharp wechselt die Plattform
Steht auch im Startbeitrag dieses Themas unter Hinweise.

Grundsätzlich ja, aber der sagt mir erstens dass er nix geblockt hat (weil whitelisted), und zweitens gehts aktuell auch wieder.
Unterschied gestern zu heute: Ich sitz physikalisch vorm Rechner, vs. RDP gestern.

Ich würd mal sagen: ist ein transientes me-Problem, und für euch egal.
private Nachricht | Beiträge des Benutzers
Th69
myCSharp.de - Experte

Avatar #avatar-2578.jpg


Dabei seit:
Beiträge: 3977

beantworten | zitieren | melden

Ich kann aber auch bestätigen, daß manchmal die Auswahl eines Smilies oder einer Farbe nicht funktioniert, besonders wenn man mehrere hintereinander auswählen möchte.
Ab und zu klappt es dann wieder, wenn man den Focus wieder explizit auf die TextBox setzt, aber auch nicht immer.
Ich erkenne da kein System, manchmal geht es wieder (kurzzeitig), wenn man das Symbol nochmal auswählt, überwiegend aber erst nach mehr als 3-5 Versuchen.
Alle anderen Buttons funktionieren einwandfrei und erzeugen sofort die passenden Texte (auch bei deaktiviertem Focus).

PS: Auch ich verwende Firefox (z.Z. Version 87.0) mit aktiviertem Ad-Block (aber 0 blockierten Elementen) - und auch bei komplett deaktiviertem Ad-Block funktioniert die Auswahl nicht immer.
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Th69 am .
private Nachricht | Beiträge des Benutzers