Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Visual Studio 2019: Debuggen extrem langsam
hypersurf
myCSharp.de - Member



Dabei seit:
Beiträge: 511
Herkunft: Münster

Themenstarter:

Visual Studio 2019: Debuggen extrem langsam

beantworten | zitieren | melden

Hallo Leute,

ich habe letzte Woche auf Visual Studio 2019 Pro umgestellt. Leider ist das Debuggen von größeren Projekten (.NET 4.5.1) extrem langsam. Jeder Debug-Schritt dauert locker eine Sekunde. Mein Rechner ist während des Debuggens nicht mal ansatzweise ausgelastet (CPU- und Datenträgerauslastung verändern sich beim Debuggen nicht/sind nicht vorhanden).

Debugge ich dasselbe Projekt in Visual Studio 2017 (ist noch installiert), gibt es keinerlei Performance-Probleme.

Die Google-Recherche hat nicht mir leider nicht weitergeholfen.

Hatte jemand evtl. schon die gleichen Probleme mit VS2019?


Gruß hypersurf
private Nachricht | Beiträge des Benutzers
vbprogger
myCSharp.de - Experte

Avatar #avatar-1820.gif


Dabei seit:
Beiträge: 1723
Herkunft: NRW/DE

beantworten | zitieren | melden

Ist schon bekannt VS2019 16.0.0 start & debug very slow. Vielleicht nochmals hiermit How to report a problem with Visual Studio or Visual Studio Installer das Problem direkt melden.

btw: da steht aber auch dass VS2017 & VS2019 auf der gleichen Maschine vielleicht dieses Problem herbeigeführt hat.
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von vbprogger am .
Ich bin verantwortlich für das, was ich sage, nicht für das, was du verstehst.
---------
Bemerkung: ich beantworte keine Fragen via PM, denn das Forum soll ja was davon haben!
private Nachricht | Beiträge des Benutzers
gfoidl
myCSharp.de - Team

Avatar #avatar-2894.jpg


Dabei seit:
Beiträge: 7538
Herkunft: Waidring

beantworten | zitieren | melden

Hallo hypersurf,

schau auch in den Debug | Options | Debugging ob etwas aktiviert ist, das nicht unbedingt (jedesmal) benötigt wird. Z.B.
  • Debug-Symbole -- müssen heruntergeladen werden, falls nicht vorhanden
  • Enable Source Link Support -- Code-Dateien werden heruntergeladen, falls nicht existent
  • Enable source server support -- gleich wie oben
  • während des Debuggen "Show threads in source" bremst auch
Diese Punkte kannst du i.d.R. deaktivieren, außer sie werden beim Debuggen tatsächlich benötigt.

mfG Gü
Stellt fachliche Fragen bitte im Forum, damit von den Antworten alle profitieren. Daher beantworte ich solche Fragen nicht per PM.

"Alle sagten, das geht nicht! Dann kam einer, der wusste das nicht - und hat's gemacht!"
private Nachricht | Beiträge des Benutzers
hypersurf
myCSharp.de - Member



Dabei seit:
Beiträge: 511
Herkunft: Münster

Themenstarter:

beantworten | zitieren | melden

Zitat von vbprogger
btw: da steht aber auch dass VS2017 & VS2019 auf der gleichen Maschine vielleicht dieses Problem herbeigeführt hat.

Ich würde gar nicht auf die Idee kommen, beide Versionen im selben Verzeichnis zu installieren, wie es jemand in dem Thread gemacht hat.

Ich hab' mal ein entsprechendes Feedback gesendet, mal gucken ob und wann es eine Reaktion gibt.
private Nachricht | Beiträge des Benutzers