Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

Visual Studio 2017 - Ihre App wurde angehalten, aber es gibt keinen anzuzeigenden Code
Christoph1972
myCSharp.de - Member

Avatar #avatar-2726.jpg


Dabei seit:
Beiträge: 213
Herkunft: NRW

Themenstarter:

Visual Studio 2017 - Ihre App wurde angehalten, aber es gibt keinen anzuzeigenden Code

beantworten | zitieren | melden

Hallo zusammen,

ich habe ein Problem mit Visual Studio 2017 Pro. Es kommt sehr häufig vor, dass beim Starten des Debuggers, die Anwendung angehalten wird. Teileweise muss ich 3,4,5 mal das Debuggen neu starten damit das auszuführende Programm startet. Es kommt immer folgenden Meldung:
Zitat
Die Anwendung befindet sich im Haltemodus.

Ihre App wurde angehalten, aber es gibt keinen anzuzeigenden Code, da alle Threads externen Code ausgeführt haben (normalerweise System- oder Frameworkcode).

In der Ausgabe erschein dann folgende Fehlermeldungen.

Fehler
Es ist ein Problem in der WindowsBase.dll aufgetreten.
Fehler
Unbehandelte Ausnahme: System.InvalidOperationException: Die Verteilerverarbeitung wurde deaktiviert, es werden jedoch weiterhin Nachrichten verarbeitet.
bei System.Windows.Threading.Dispatcher.WndProcHook(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
bei MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
bei MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
bei System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
bei System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)
bei System.Windows.Threading.Dispatcher.LegacyInvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Int32 numArgs)
bei MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)

Ich habe keine Idee wo das herkommen kann. Bis auf MVVM Light gibt es keine fremden Komponenten in dem Projekt, kein Threading oder ähnliches.

Kann ich die Einstellungen für den Debugger möglicherweise anpassen? Einen Abgleich der Einstellungen für den Debugger habe ich mit einem zweiten Rechner bereits durchgeführt und konnte keine Unterschiede feststellen. Ich denke meine Installationen laufen mit den Standardeinstellungen.

Bei der Suche mit Google habe ich zu dem Thema ein Post in einem anderen Forum gefunden, leider ohne Reaktion.

Vielleicht hat ja hier jemand eine Idee wie ich das Problem in den Griff bekommen kann? Teilweise nervt das extrem.

LG
Christoph
Gruß
Christoph
private Nachricht | Beiträge des Benutzers
Papst
myCSharp.de - Experte



Dabei seit:
Beiträge: 394
Herkunft: Kassel

beantworten | zitieren | melden

Zu deiner Fehlermeldung habe ich im msdn Forum einen Thread gefunden.

Da ich deinen Code nicht kenne kann ich das nicht beurteilen ob es die gleiche Ursache ist.
private Nachricht | Beiträge des Benutzers
Christoph1972
myCSharp.de - Member

Avatar #avatar-2726.jpg


Dabei seit:
Beiträge: 213
Herkunft: NRW

Themenstarter:

beantworten | zitieren | melden

Vielen Dank für die Unterstützung!
Zitat von Papst
Da ich deinen Code nicht kenne kann ich das nicht beurteilen ob es die gleiche Ursache ist.

Nein, das kann/sollte nicht die gleiche Ursache sein. Es gibt in dem Projekt kein Code behind, also auch kein Zugriff auf irgendwelche Controls oder ähnliches.
Gruß
Christoph
private Nachricht | Beiträge des Benutzers
unconnected
myCSharp.de - Member

Avatar #avatar-3200.jpg


Dabei seit:
Beiträge: 862
Herkunft: Oerlinghausen/NRW

beantworten | zitieren | melden

Zitat
Es gibt in dem Projekt kein Code behind

Das ist unerheblich. Du kannst so eine Endlosschleife auch im Xaml erzeugen.
Aber wie schon gesagt, ohne Code/Xaml ist das unmöglich zu analysieren.
private Nachricht | Beiträge des Benutzers
p!lle
myCSharp.de - Member

Avatar #avatar-3556.jpg


Dabei seit:
Beiträge: 1053

beantworten | zitieren | melden

Schau mal, ob du den Fehler damit eingrenzen kannst: [Tutorial] Vertrackte Fehler durch Vergleich von echtem Projekt mit minimalem Testprojekt finden
private Nachricht | Beiträge des Benutzers
Christoph1972
myCSharp.de - Member

Avatar #avatar-2726.jpg


Dabei seit:
Beiträge: 213
Herkunft: NRW

Themenstarter:

beantworten | zitieren | melden

Hallo zusammen,

vielen Dank für die Unterstützung!

Also, ich habe heute alle .pdb und .xml Dateien in dem Debug Ordner gelöscht. Jetzt kommt die Fehlermeldung nicht mehr und das Debuggen startet erheblich schneller. Eigentlich wird doch bei "Projektmappe" neu erstellen bzw. bereinigen auch alles gelöscht, oder? Das hatte ich letzte Woche gemacht, ohne Erfolg. Was mir aufgefallen ist, es wird immer eine Datei (GalaSoft.MvvmLight.Platform.pdb) vom MVVM Light Tool Kit in dem Ordner erzeugt. Kommt der Debugger möglicherweise mit dieser Datei durcheinander? Warum wird diese Datei überhaupt angelegt??

@unconnected
Müsste es bei einer Endlosschleife nicht so sein, das der Fehler immer kommt und nicht nur sporadisch?
Gruß
Christoph
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 16147

beantworten | zitieren | melden

Zitat von Christoph1972
Eigentlich wird doch bei "Projektmappe" neu erstellen bzw. bereinigen auch alles gelöscht, oder?
Nein.

Die PDB-Datei wird vermutlich aus dem NuGet kommen, das Du konsumierst.
Dadurch kann auch das Zeug gedebuggt werden.
- performance is a feature -

Microsoft MVP - @Website - @blog - @AzureStuttgart - github.com/BenjaminAbt
private Nachricht | Beiträge des Benutzers
unconnected
myCSharp.de - Member

Avatar #avatar-3200.jpg


Dabei seit:
Beiträge: 862
Herkunft: Oerlinghausen/NRW

beantworten | zitieren | melden

Hallo Christoph,
Zitat
Müsste es bei einer Endlosschleife nicht so sein, das der Fehler immer kommt und nicht nur sporadisch?

Nicht unbedingt. Machmal entstehen solche Schleifen auch durch Race Conditions. Aber eher selten.
private Nachricht | Beiträge des Benutzers
Christoph1972
myCSharp.de - Member

Avatar #avatar-2726.jpg


Dabei seit:
Beiträge: 213
Herkunft: NRW

Themenstarter:

beantworten | zitieren | melden

Guten Morgen zusammen!
Zitat von Abt
Zitat von Christoph1972
Eigentlich wird doch bei "Projektmappe" neu erstellen bzw. bereinigen auch alles gelöscht, oder?

Ah, ok. Das hatte ich bei "Projektmappe bereinigen" bisher gedacht. Aber gut zu wissen, das stimmt mich um so optimistischer dass das Problem damit behoben ist.

Zitat von Abt
Die PDB-Datei wird vermutlich aus dem NuGet kommen, das Du konsumierst.
Dadurch kann auch das Zeug gedebuggt werden.

Ist das eine Konfigurationssache von Nuget? pdb's werden ja nicht zwangsläufig bei Nuget-Unterstützung angelegt.

Das es ein Problem mit neinem XAML gibt kann ich aktuell nur schwer glauben, aber das wer weiss......

Falls das Problem wieder auftaucht, werde ich mich hier noch mal melden!

Vielen Dank für die Unterstützung!
Gruß
Christoph
private Nachricht | Beiträge des Benutzers
Abt
myCSharp.de - Team

Avatar #avatar-4119.png


Dabei seit:
Beiträge: 16147

beantworten | zitieren | melden

Zitat von Christoph1972

Ist das eine Konfigurationssache von Nuget? pdb's werden ja nicht zwangsläufig bei Nuget-Unterstützung angelegt.

In das NuGet Paket kommt das, was der Entwickler eben beim Erstellen der nuspec angibt.
Das können auch Word-Dateien sein.
- performance is a feature -

Microsoft MVP - @Website - @blog - @AzureStuttgart - github.com/BenjaminAbt
private Nachricht | Beiträge des Benutzers
Christoph1972
myCSharp.de - Member

Avatar #avatar-2726.jpg


Dabei seit:
Beiträge: 213
Herkunft: NRW

Themenstarter:

beantworten | zitieren | melden

Hallo Zusammen,

ich muss das Problem noch mal nach oben holen, da es nicht - wie gedacht - behoben ist. Das beschriebene Problem holt mich sporadisch immer wieder ein.

Das aktuelle Projekt habe nach und nach zurückgebaut, bis quasi nur noch ein nacktes Window übrigblieb, um sicherzustellen, dass ich die Exception nicht mit meinem eigenen Code auslöse. Die Exception kommt aber auch mit minimalsten Code.

Zwischenzeitlich hat sich herausgestellt, dass dieses Problem nicht Projekt bezogen ist und auch in anderen Projekten auftritt und je mehr Code ein Projekt hat, desto häufiger tritt es auf. Zudem habe ich das Projekt, bei dem die Exception am häufigsten kommt, auch auf einem anderen Rechner getestet und konnte das Problem soweit nicht nachstellen. Das Problem besteht scheinbar nur auf meinem Gerät. Ohne Debugger kann ich das Problem soweit auch nicht nachstellen, was aber nichts heißen muss.

In der App.xaml.cs sind folgende ExceptionEventHandler abonniert und diese werden vor der Meldung im Visual Studio auch geworfen.


DispatcherUnhandledException
AppDomain.CurrentDomain.UnhandledException

Source bei der Exception ist immer die WindowsBase.dll

Das Problem muss ich irgendwie beheben, da der Debugger temporär nicht mehr gestartet werden kann und das behindert mich dann sehr.

Wie würdet ihr weiter vorgehen, was kann ich noch unternehmen?
Gruß
Christoph
private Nachricht | Beiträge des Benutzers
p!lle
myCSharp.de - Member

Avatar #avatar-3556.jpg


Dabei seit:
Beiträge: 1053

beantworten | zitieren | melden

Kannst du das Minimalprojekt mal zur Verfügung stellen?
private Nachricht | Beiträge des Benutzers
Christoph1972
myCSharp.de - Member

Avatar #avatar-2726.jpg


Dabei seit:
Beiträge: 213
Herkunft: NRW

Themenstarter:

beantworten | zitieren | melden

Hallo zusammen,


gut möglich das ich das Problem jetzt los bin, zumindest ist es in der vergangenen Woche nicht mehr aufgetreten. Da ich schon mal geglaubt habe, dass ich das Problem los sei, bin ich mit der Aussage doch ehr vorsichtig.

Ich hatte bereits das VS neu installiert, ohne Erfolg. Letztendlich habe ich mich dazu entschlossen, das Windows neu zu installieren und nun startet der Debugger spürbar schneller und das Problem ist bisher nicht mehr aufgetreten. Ich bin nun erstmal optimistisch! =)

Vielen Danke für eure Unterstützung, wirklich sehr nett!!
Gruß
Christoph
private Nachricht | Beiträge des Benutzers