Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
Problem beim debuggen aus Win Forms in lokalen WS
Steven85
myCSharp.de - Member



Dabei seit:
Beiträge: 91

Themenstarter:

Problem beim debuggen aus Win Forms in lokalen WS

beantworten | zitieren | melden

Hallo Zusammen,

seit kurzen habe ich ein Problem damit aus ein Windows Anwendung in meinen lokalen WS zu debuggen, per Einzelschritt. Hier kommt die angehängte Fehlermeldung.

Bevor ich jetzt den kompletten Code poste, hoffe ich das jemand evtl. auf anhieb weiß woher diese Fehlermeldung kommt.

Danke schonmal
Attachments
private Nachricht | Beiträge des Benutzers
unconnected
myCSharp.de - Member

Avatar #avatar-3200.jpg


Dabei seit:
Beiträge: 862
Herkunft: Oerlinghausen/NRW

beantworten | zitieren | melden

Hallo,

sieht mir aus, als wenn die dll auf dem Server nicht mit dem aktuellen Source Code stand übereinstimmt.
private Nachricht | Beiträge des Benutzers
Steven85
myCSharp.de - Member



Dabei seit:
Beiträge: 91

Themenstarter:

beantworten | zitieren | melden

Daran habe ich auch schon gedacht, muss ich was bestimmtes löschen an einem bestimmten Ort damit es neu erstellt wird?
private Nachricht | Beiträge des Benutzers
felix
myCSharp.de - Member



Dabei seit:
Beiträge: 187

beantworten | zitieren | melden

Ist schon eine Zeit her, dass ich mit SOAP gearbeitet habe, aber ich hatte solche Meldungen auch schon. Und es lag eigentlich immer daran, dass die Proxy-Klasse nicht aktuell war. Im Grunde also das, was dir unconnected auch schon gesagt hat. Die Proxy-Klasse kannst du dir aber ganz einfach über die VisualStudio Tools neu generieren lassen.
private Nachricht | Beiträge des Benutzers
Steven85
myCSharp.de - Member



Dabei seit:
Beiträge: 91

Themenstarter:

beantworten | zitieren | melden

Wie genau mache ich das?
private Nachricht | Beiträge des Benutzers
felix
myCSharp.de - Member



Dabei seit:
Beiträge: 187

beantworten | zitieren | melden

Schau' mal hier:
How to: Add, Update, or Remove a Service Reference
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von felix am .
private Nachricht | Beiträge des Benutzers
unconnected
myCSharp.de - Member

Avatar #avatar-3200.jpg


Dabei seit:
Beiträge: 862
Herkunft: Oerlinghausen/NRW

beantworten | zitieren | melden

Ist die in der Fehlermeldung erwähnte nicht gefundene Funktion von dir oder einem 3´t Anbieter?


Um sicher zu gehen solltest Du einen Clean & Rebuild (DEBUG) deiner Solution anstossen, und alle files (exe, dlls, pdb) löschen und mit deinen neu kompilierten ersetzen.

Wenn das auch nichts bringt, hilft manchmal auch ein Restart des Visual Studios (inkl. löschen der verstecken .suo Datei). Danach nochmal den ersten Schritt wiederholen.
private Nachricht | Beiträge des Benutzers
Steven85
myCSharp.de - Member



Dabei seit:
Beiträge: 91

Themenstarter:

beantworten | zitieren | melden

Die WebMethode ist meine eigene. Leider hilft auch das löschen und neu erstellen der dlls nicht.
Komisch ist das ich aus einer anderen Konsolenanwendung in den WS debuggen kann. Es läuft alles lokal über einen WS der auch lokal ist. Die Konsolenanwendung ist doch im Grunde nichts anderes wie die Win Anwendung.
Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Steven85 am .
private Nachricht | Beiträge des Benutzers