Willkommen auf myCSharp.de! Anmelden | kostenlos registrieren
 | Suche | FAQ

Hauptmenü
myCSharp.de
» Startseite
» Forum
» Suche
» Regeln
» Wie poste ich richtig?

Mitglieder
» Liste / Suche
» Wer ist online?

Ressourcen
» FAQ
» Artikel
» C#-Snippets
» Jobbörse
» Microsoft Docs

Team
» Kontakt
» Cookies
» Spenden
» Datenschutz
» Impressum

  • »
  • Community
  • |
  • Diskussionsforum
VS 2010 Express: .NET 4.5 Unterstützung?
CSharperUser
myCSharp.de - Member



Dabei seit:
Beiträge: 81

Themenstarter:

VS 2010 Express: .NET 4.5 Unterstützung?

beantworten | zitieren | melden

Hallo zusammen,

Laut Microsoft soll die Express-Edition von VS 11 (bzw. VS 2012) nur Metro-Anwendungen ermöglichen, für Desktop-Anwendungen soll man weiterhin die Express-Edition von VS 2010 verwenden, wenn man auf keine höhere Version umsteigen will.

Weiß eventuell jemand, ob es für VS 2010 eine .NET 4.5 Unterstützung (Bsp. über Service Pack) geben wird? Sonst wäre man als Express-Anwender genötigt, auf eine höhere Version umzusteigen.

Wann wird denn die VS 11 Express Version erscheinen?
private Nachricht | Beiträge des Benutzers
bredator
myCSharp.de - Member



Dabei seit:
Beiträge: 368

beantworten | zitieren | melden

Mein Wissensstand ist, dass von VS2012 Express-Editionen erscheinen, die aber, wie du schon sagtest, nur für Metro-Anwendungen nutzbar sind. Für Desktop-Anwendungen müssen entweder die VS2010er Versionen oder Professional etc. von 2012 her. VS2010 geht nur bis .NET 4.0, zumindest solange MS es nicht darauf trimmt, auch .NET4.5 zu können. Und das halte ich für sehr unwahrscheinlich. Zumindest gab es das bei VS2008 auch nicht, dass man es nachträglich .NET4.0-kompatibel gemacht hätte, also würde ich von einem schlichten 'nein' ausgehen.

Irgendwo hatte ich was zu den Preisen von VS2012 gelesen und dass die Professional-Version zumindest einiges billiger wird, als dasselbe von der 2010er-Ausgabe. Falls das immer noch zu teuer ist für so manchen, wird nichts anderes übrig bleiben, als auf .NET4.5 zu verzichten oder sich mal in der Mono-Ecke schlau zu machen, ob und was dort so geboten wird. Da WPF nicht dabei ist, ist Mono für mich leider gleich wieder erledigt, aber das sieht bei jedem halt anders aus.

Für Schüler, Studenten und frische Gewerbetreibende gibt es aber extrem günstige/kostenlose Möglichkeiten, an die größeren Ausgaben von VS zu kommen. Dreamspark, Bizspark und diverse weitere Angebote von MS kommen einem da sehr entgegen.

Die Express-Editionen von VS werden, wie bei der 2010er vermutlich gleichzeitig oder 1-2 Wochen nach dem großen VS erscheinen, also wohl irgendwann im Spätsommer oder Herbst.
private Nachricht | Beiträge des Benutzers
talla
myCSharp.de - Experte

Avatar #avatar-3214.jpg


Dabei seit:
Beiträge: 7290
Herkunft: Esslingen

beantworten | zitieren | melden

Ich denke nicht das es für 2010 nen Update auf .Net 4.5 geben wird. Sie wollen ja Metro forcieren und haben genau aus dem Grund die Unterstützung für Desktop Projekte aus VS 20122 EE entfernt. (Wobei mir ehrlich gesagt nicht ganz klar ist, wie sie das anstellen, da der Compiler ja sowieso der gleiche bleibt und ich nicht sehe, wie man MSBuild vorschreiben soll, keine normalen Desktop Anwendungen zu erstellen - vielleicht reichen im Endeffekt auch einfach angepasste Projektvorlagen aus)

@bredator
Deine Schlüsse stimmen so nicht ganz. Man kann problemlos mit dem MS .net Framework weiterhin kostenlos .Net 4.5 Desktop Anwendungen erstellen, nur nicht mit VS 2012 Express als IDE. #Develop z.B. kann das aber problemlos wenn das 4.5er Framework installiert ist. Man muss nicht zwangsweise auf Mono zurückgreifen für Desktopanwendungen.
Baka wa shinanakya naoranai.

Mein XING Profil.
private Nachricht | Beiträge des Benutzers
husky410
myCSharp.de - Member

Avatar #avatar-1712.jpeg


Dabei seit:
Beiträge: 229
Herkunft: Ruhrgebiet

beantworten | zitieren | melden

Also wenn ich mich recht erinnere gab es das noch nie, das der Support einer älteren VS Version für ein neueres Framework aktualisiert wurde... würde ich auch nicht machen wollen als Hersteller, dafür gabe es dann doch immer die neue Expressvariante, die dann abwärtskompatibel ist...
private Nachricht | Beiträge des Benutzers
bredator
myCSharp.de - Member



Dabei seit:
Beiträge: 368

beantworten | zitieren | melden

@talla
Da hab ich mich wohl etwas unglücklich ausgedrückt, da ich eigentlich MonoDevelop als IDE meinte und nicht das Framework Mono ;)
private Nachricht | Beiträge des Benutzers
talla
myCSharp.de - Experte

Avatar #avatar-3214.jpg


Dabei seit:
Beiträge: 7290
Herkunft: Esslingen

beantworten | zitieren | melden

Du hast immerhin davon geredet, dass WPF nicht bei ist, was doch eindeutig auf das Framework hindeutet :)
Baka wa shinanakya naoranai.

Mein XING Profil.
private Nachricht | Beiträge des Benutzers
weismat
myCSharp.de - Member



Dabei seit:
Beiträge: 878
Herkunft: Frankfurt am Main

beantworten | zitieren | melden

MSBuild gehoert zum Plattform-SDK und das ist auch in der Zusammensetzung mit Windows 8 geaendert wird, da die Compiler jetzt eigene Komponenten geworden sind und somit keine vollstaendige Build-Umgebung mehr ist.
Siehe Windows Software Development Kit (SDK) for Windows 8 Release Preview.
private Nachricht | Beiträge des Benutzers
weismat
myCSharp.de - Member



Dabei seit:
Beiträge: 878
Herkunft: Frankfurt am Main

beantworten | zitieren | melden

MS wird wohl VS Express 2012 anpassen, so dass Desktop auch unterstützt wird - siehe hier
private Nachricht | Beiträge des Benutzers