Laden...

Kein login auf website möglich

Erstellt von alpagal vor 11 Jahren Letzter Beitrag vor 11 Jahren 1.024 Views
A
alpagal Themenstarter:in
27 Beiträge seit 2012
vor 11 Jahren
Kein login auf website möglich

Hallo

Ich habe meine Webseite auf dem Server geladen. Nachdem ich auf login drücke bekomme ich die Fehlermeldung.
Mir gehts darum, dass ich die selben rollen, und user habe die ich eben in der standard ASPNETDB.mdf habe.
Habe die datenbank über rechtsklick auf Datenbankordner-Attatch verknüpft.

Irgendwas mache ich falsch und über google konnte ich bisher nicht wirklich was hilfreiches finden.

Danke

16.773 Beiträge seit 2008
vor 11 Jahren

Benutz einen richtigen DB Server statt die Attached Files.
Eventuell ist dann das Problem schon weg.

B
198 Beiträge seit 2005
vor 11 Jahren

Kannst du bitte einmal deinen ConnectionString posten?

A
alpagal Themenstarter:in
27 Beiträge seit 2012
vor 11 Jahren

Benutz einen richtigen DB Server statt die Attached Files.
Eventuell ist dann das Problem schon weg.

Ich habe versucht die db richtig zu importieren aber da kann ich nur von einem auf den anderen importieren. Die einzige möglichkeit die mdf datei auf in dem sql server auf meinem server zu bekommen war eben das mit attatch.

Das ist der connection string aus der web.config:

<add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;User Instance=true"
B
198 Beiträge seit 2005
vor 11 Jahren

Hallo,

Wo führst du die Anwendung denn aus? Im IIS oder im Development Server?

Es scheint ein Problem mit dem Benutzer zu geben...

Hast du in der web.config folgenden Eintrag?

<anonymousIdentification enabled="true"/>

Versuch einmal die anonymousIdentification auf true zu setzen und schau ob es dann funktioniert.